summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/files/samba-4.16.2-fix-musl-without-innetgr.patch23
-rw-r--r--net-fs/samba/samba-4.16.2.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/net-fs/samba/files/samba-4.16.2-fix-musl-without-innetgr.patch b/net-fs/samba/files/samba-4.16.2-fix-musl-without-innetgr.patch
new file mode 100644
index 000000000000..c0b1746fc31a
--- /dev/null
+++ b/net-fs/samba/files/samba-4.16.2-fix-musl-without-innetgr.patch
@@ -0,0 +1,23 @@
+# Gentoo bug 855047
+--- a/lib/util/access.c
++++ b/lib/util/access.c
+@@ -115,7 +115,7 @@ static bool string_match(const char *tok,const char *s)
+ return true;
+ }
+ } else if (tok[0] == '@') { /* netgroup: look it up */
+-#ifdef HAVE_NETGROUP
++#if defined(HAVE_NETGROUP) && defined(HAVE_INNETGR)
+ DATA_BLOB tmp;
+ char *mydomain = NULL;
+ char *hostname = NULL;
+--- a/source3/auth/user_util.c
++++ b/source3/auth/user_util.c
+@@ -135,7 +135,7 @@ static void store_map_in_gencache(TALLOC_CTX *ctx, const char *from, const char
+
+ bool user_in_netgroup(TALLOC_CTX *ctx, const char *user, const char *ngname)
+ {
+-#ifdef HAVE_NETGROUP
++#if defined(HAVE_NETGROUP) && defined(HAVE_INNETGR)
+ char nis_domain_buf[256];
+ const char *nis_domain = NULL;
+ char *lowercase_user = NULL;
diff --git a/net-fs/samba/samba-4.16.2.ebuild b/net-fs/samba/samba-4.16.2.ebuild
index 090a59c32be1..e5115c4e9c41 100644
--- a/net-fs/samba/samba-4.16.2.ebuild
+++ b/net-fs/samba/samba-4.16.2.ebuild
@@ -142,6 +142,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}/${PN}-4.4.0-pam.patch"
"${FILESDIR}/${PN}-4.16.1-netdb-defines.patch"
+ "${FILESDIR}/${PN}-4.16.2-fix-musl-without-innetgr.patch"
)
#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"