summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/oneclickftp')
-rw-r--r--net-ftp/oneclickftp/Manifest1
-rw-r--r--net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch13
-rw-r--r--net-ftp/oneclickftp/metadata.xml8
-rw-r--r--net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild34
4 files changed, 56 insertions, 0 deletions
diff --git a/net-ftp/oneclickftp/Manifest b/net-ftp/oneclickftp/Manifest
new file mode 100644
index 000000000000..b439a0dd6162
--- /dev/null
+++ b/net-ftp/oneclickftp/Manifest
@@ -0,0 +1 @@
+DIST oneclickftp-0.5.1.tar.gz 109759 SHA256 91a36cd7c2fb53e7ca6e7bef4d7ff62cf2c72967b242290184b4530326bd39b5
diff --git a/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch b/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch
new file mode 100644
index 000000000000..bea8e32af477
--- /dev/null
+++ b/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch
@@ -0,0 +1,13 @@
+Index: oneclickftp-0.5.1/src/ftpwindowimpl.h
+===================================================================
+--- oneclickftp-0.5.1.orig/src/ftpwindowimpl.h
++++ oneclickftp-0.5.1/src/ftpwindowimpl.h
+@@ -38,7 +38,7 @@ class FTPWindowImpl : public QWidget, pu
+ {
+ Q_OBJECT
+ public:
+- FTPWindowImpl(QString Dir, QString Profile, QString ProxyIP = 0, QString ProxyPort = 0);
++ FTPWindowImpl(QString Dir, QString Profile, QString ProxyIP = QString::number(0), QString ProxyPort = QString::number(0));
+ bool Upload(OProfile *ProfiletoUpload, std::vector<OFileConnection*> SelectedFiles);
+ bool Download(OProfile *ProfiletoDownload, std::vector<OFileConnection*> SelectedFiles);
+
diff --git a/net-ftp/oneclickftp/metadata.xml b/net-ftp/oneclickftp/metadata.xml
new file mode 100644
index 000000000000..4b2e4c0373d9
--- /dev/null
+++ b/net-ftp/oneclickftp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">oneclickftp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
new file mode 100644
index 000000000000..893c23551595
--- /dev/null
+++ b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils qt4-r2
+
+DESCRIPTION="The somehow different FTP client"
+HOMEPAGE="http://oneclickftp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ || ( app-crypt/qca:2 app-crypt/qca:2[qt4] )
+ dev-qt/qtgui:4"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-qt47.patch
+)
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die
+ doicon res/icons/${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ dodoc CHANGELOG
+}