summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/empathy')
-rw-r--r--net-im/empathy/Manifest3
-rw-r--r--net-im/empathy/empathy-3.12.10.ebuild127
-rw-r--r--net-im/empathy/empathy-3.12.7.ebuild127
-rw-r--r--net-im/empathy/empathy-3.12.9.ebuild127
-rw-r--r--net-im/empathy/files/empathy-3.12.7-Fix-parallel-build-in-extensions.patch65
-rw-r--r--net-im/empathy/metadata.xml22
6 files changed, 471 insertions, 0 deletions
diff --git a/net-im/empathy/Manifest b/net-im/empathy/Manifest
new file mode 100644
index 000000000000..00abc94d2de8
--- /dev/null
+++ b/net-im/empathy/Manifest
@@ -0,0 +1,3 @@
+DIST empathy-3.12.10.tar.xz 5064384 SHA256 794140c3743aa83739ef7efa9eff1950e2f718fde9dc29064fa9d616478e97cb SHA512 59d48316d4708e04cddb395626ac1e8fc55aa215e1bbb79e6976c58c857f08e8a758ccc670a35bd966b95676a2cdd6bc70dd12e3aac85d01e02e995bb6fd6fe2 WHIRLPOOL 1391448c99876746471273dcabc47e8c1119be98d415e0e7ee7b31391c3dbc029ef952176b567d59fd9c0300ab5be3102302237b488bd4c9ecef214831db0c96
+DIST empathy-3.12.7.tar.xz 5047116 SHA256 abcc6e325474d158ba21dfc864183617cf832c3570ccefe9e32f275b94452794 SHA512 4c0c6ba19fbf200c6171ccf1935ffb862d1a22ccfd705dff7bac7230ff22330d5244e8330e9a84f8aadaae726384f37b8ebc594d015cab07fdb3bc6386acbc47 WHIRLPOOL 833962c303c1518a6aa2d5327877ea5a9e99be7d26814c4692c78b978c090802765ab27a697b689757f17dd7a2fa062270fdc44f2488ce4919bdd87db2427a01
+DIST empathy-3.12.9.tar.xz 5060040 SHA256 743d3f1826afb6f1f6751983a780443da315635e1f05345370564c8cd541c422 SHA512 5aa01a6be70a708d8d7f6d7950d5f71110386a3e5633e169f6ac29ee036d73bcb3237ce80e424915decec5cfd79235cf76c067dc9f810f34dd2443cf733d9c6c WHIRLPOOL 3089843d8e8049d79b414dca43c350d568125e01ec0d468564e6d4735fbd4e50d7d59bdf7c3be51b18a0f4b356a6cd2ae7a4c7f956e297a88b26478c994f5cf3
diff --git a/net-im/empathy/empathy-3.12.10.ebuild b/net-im/empathy/empathy-3.12.10.ebuild
new file mode 100644
index 000000000000..c589840621bc
--- /dev/null
+++ b/net-im/empathy/empathy-3.12.10.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit gnome2 autotools python-any-r1 virtualx
+
+DESCRIPTION="Telepathy instant messaging and video/audio call client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Empathy"
+
+LICENSE="GPL-2 CC-BY-SA-3.0 FDL-1.3 LGPL-2.1"
+SLOT="0"
+
+IUSE="debug +geoloc gnome gnome-online-accounts +map spell test +v4l"
+
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+# gdk-pixbuf and pango extensively used in libempathy-gtk
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.6:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.9.4:3
+ x11-libs/pango
+ >=dev-libs/dbus-glib-0.51
+ >=dev-libs/folks-0.9.5:=[telepathy]
+ dev-libs/libgee:0.8=
+ >=app-crypt/libsecret-0.5
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/gnutls-2.8.5:=
+ >=net-libs/webkit-gtk-1.9.1:3
+ >=x11-libs/libnotify-0.7:=
+
+ media-libs/gstreamer:1.0
+ >=media-libs/clutter-1.10.0:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ media-libs/clutter-gst:2.0
+ >=media-libs/cogl-1.14:1.0=
+
+ net-libs/farstream:0.2=
+ >=net-libs/telepathy-farstream-0.6.0:=
+ >=net-libs/telepathy-glib-0.23.2
+ >=net-im/telepathy-logger-0.8.0:=
+
+ app-crypt/gcr
+ dev-libs/libxml2:2
+ gnome-base/gsettings-desktop-schemas
+ media-sound/pulseaudio[glib]
+ net-libs/libsoup:2.4
+ x11-libs/libX11
+
+ geoloc? (
+ >=app-misc/geoclue-2.1:2.0
+ >=sci-geosciences/geocode-glib-3.10 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.5.1 )
+ map? (
+ >=media-libs/clutter-1.7.14:1.0
+ >=media-libs/clutter-gtk-0.90.3:1.0
+ >=media-libs/libchamplain-0.12.1:0.12[gtk] )
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35 )
+ v4l? (
+ media-plugins/gst-plugins-v4l2:1.0
+ >=media-video/cheese-3.4:=
+ virtual/libgudev:= )
+"
+
+# >=empathy-3.4 is incompatible with telepathy-rakia-0.6, bug #403861
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-base:1.0
+ net-im/telepathy-connection-managers
+ !<net-voip/telepathy-rakia-0.7
+ x11-themes/gnome-icon-theme-symbolic
+ gnome? ( gnome-extra/gnome-contacts )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50.0
+ virtual/pkgconfig
+ test? (
+ sys-apps/grep
+ >=dev-libs/check-0.9.4 )
+"
+PDEPEND=">=net-im/telepathy-mission-control-5.14"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ export PYTHONIOENCODING=UTF-8 # See bug 489774
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.12.7-Fix-parallel-build-in-extensions.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="CONTRIBUTORS AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --disable-Werror \
+ --disable-coding-style-checks \
+ --disable-static \
+ --disable-ubuntu-online-accounts \
+ --enable-gst-1.0 \
+ $(use_enable debug) \
+ $(use_enable geoloc geocode) \
+ $(use_enable geoloc location) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable map) \
+ $(use_enable spell) \
+ $(use_enable v4l gudev) \
+ $(use_with v4l cheese) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ dbus-launch Xemake check #504516
+}
diff --git a/net-im/empathy/empathy-3.12.7.ebuild b/net-im/empathy/empathy-3.12.7.ebuild
new file mode 100644
index 000000000000..62d960d7d9e2
--- /dev/null
+++ b/net-im/empathy/empathy-3.12.7.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit gnome2 autotools python-any-r1 virtualx
+
+DESCRIPTION="Telepathy instant messaging and video/audio call client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Empathy"
+
+LICENSE="GPL-2 CC-BY-SA-3.0 FDL-1.3 LGPL-2.1"
+SLOT="0"
+
+IUSE="debug +geoloc gnome gnome-online-accounts +map spell test +v4l"
+
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+# gdk-pixbuf and pango extensively used in libempathy-gtk
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.6:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.9.4:3
+ x11-libs/pango
+ >=dev-libs/dbus-glib-0.51
+ >=dev-libs/folks-0.9.5:=[telepathy]
+ dev-libs/libgee:0.8=
+ >=app-crypt/libsecret-0.5
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/gnutls-2.8.5:=
+ >=net-libs/webkit-gtk-1.9.1:3
+ >=x11-libs/libnotify-0.7:=
+
+ media-libs/gstreamer:1.0
+ >=media-libs/clutter-1.10.0:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ media-libs/clutter-gst:2.0
+ >=media-libs/cogl-1.14:1.0=
+
+ net-libs/farstream:0.2=
+ >=net-libs/telepathy-farstream-0.6.0:=
+ >=net-libs/telepathy-glib-0.23.2
+ >=net-im/telepathy-logger-0.8.0:=
+
+ app-crypt/gcr
+ dev-libs/libxml2:2
+ gnome-base/gsettings-desktop-schemas
+ media-sound/pulseaudio[glib]
+ net-libs/libsoup:2.4
+ x11-libs/libX11
+
+ geoloc? (
+ >=app-misc/geoclue-1.99.3:2.0
+ >=sci-geosciences/geocode-glib-3.10 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.5.1 )
+ map? (
+ >=media-libs/clutter-1.7.14:1.0
+ >=media-libs/clutter-gtk-0.90.3:1.0
+ >=media-libs/libchamplain-0.12.1:0.12[gtk] )
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35 )
+ v4l? (
+ media-plugins/gst-plugins-v4l2:1.0
+ >=media-video/cheese-3.4:=
+ virtual/libgudev:= )
+"
+
+# >=empathy-3.4 is incompatible with telepathy-rakia-0.6, bug #403861
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-base:1.0
+ net-im/telepathy-connection-managers
+ !<net-voip/telepathy-rakia-0.7
+ x11-themes/gnome-icon-theme-symbolic
+ gnome? ( gnome-extra/gnome-contacts )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50.0
+ virtual/pkgconfig
+ test? (
+ sys-apps/grep
+ >=dev-libs/check-0.9.4 )
+"
+PDEPEND=">=net-im/telepathy-mission-control-5.14"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ export PYTHONIOENCODING=UTF-8 # See bug 489774
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.12.7-Fix-parallel-build-in-extensions.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="CONTRIBUTORS AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --disable-Werror \
+ --disable-coding-style-checks \
+ --disable-static \
+ --disable-ubuntu-online-accounts \
+ --enable-gst-1.0 \
+ $(use_enable debug) \
+ $(use_enable geoloc geocode) \
+ $(use_enable geoloc location) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable map) \
+ $(use_enable spell) \
+ $(use_enable v4l gudev) \
+ $(use_with v4l cheese) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ dbus-launch Xemake check #504516
+}
diff --git a/net-im/empathy/empathy-3.12.9.ebuild b/net-im/empathy/empathy-3.12.9.ebuild
new file mode 100644
index 000000000000..9fc57eb07e26
--- /dev/null
+++ b/net-im/empathy/empathy-3.12.9.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit gnome2 autotools python-any-r1 virtualx
+
+DESCRIPTION="Telepathy instant messaging and video/audio call client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Empathy"
+
+LICENSE="GPL-2 CC-BY-SA-3.0 FDL-1.3 LGPL-2.1"
+SLOT="0"
+
+IUSE="debug +geoloc gnome gnome-online-accounts +map spell test +v4l"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+# gdk-pixbuf and pango extensively used in libempathy-gtk
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.6:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.9.4:3
+ x11-libs/pango
+ >=dev-libs/dbus-glib-0.51
+ >=dev-libs/folks-0.9.5:=[telepathy]
+ dev-libs/libgee:0.8=
+ >=app-crypt/libsecret-0.5
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/gnutls-2.8.5:=
+ >=net-libs/webkit-gtk-1.9.1:3
+ >=x11-libs/libnotify-0.7:=
+
+ media-libs/gstreamer:1.0
+ >=media-libs/clutter-1.10.0:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ media-libs/clutter-gst:2.0
+ >=media-libs/cogl-1.14:1.0=
+
+ net-libs/farstream:0.2=
+ >=net-libs/telepathy-farstream-0.6.0:=
+ >=net-libs/telepathy-glib-0.23.2
+ >=net-im/telepathy-logger-0.8.0:=
+
+ app-crypt/gcr
+ dev-libs/libxml2:2
+ gnome-base/gsettings-desktop-schemas
+ media-sound/pulseaudio[glib]
+ net-libs/libsoup:2.4
+ x11-libs/libX11
+
+ geoloc? (
+ >=app-misc/geoclue-2.1:2.0
+ >=sci-geosciences/geocode-glib-3.10 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.5.1 )
+ map? (
+ >=media-libs/clutter-1.7.14:1.0
+ >=media-libs/clutter-gtk-0.90.3:1.0
+ >=media-libs/libchamplain-0.12.1:0.12[gtk] )
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35 )
+ v4l? (
+ media-plugins/gst-plugins-v4l2:1.0
+ >=media-video/cheese-3.4:=
+ virtual/libgudev:= )
+"
+
+# >=empathy-3.4 is incompatible with telepathy-rakia-0.6, bug #403861
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-base:1.0
+ net-im/telepathy-connection-managers
+ !<net-voip/telepathy-rakia-0.7
+ x11-themes/gnome-icon-theme-symbolic
+ gnome? ( gnome-extra/gnome-contacts )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50.0
+ virtual/pkgconfig
+ test? (
+ sys-apps/grep
+ >=dev-libs/check-0.9.4 )
+"
+PDEPEND=">=net-im/telepathy-mission-control-5.14"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ export PYTHONIOENCODING=UTF-8 # See bug 489774
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.12.7-Fix-parallel-build-in-extensions.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="CONTRIBUTORS AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --disable-Werror \
+ --disable-coding-style-checks \
+ --disable-static \
+ --disable-ubuntu-online-accounts \
+ --enable-gst-1.0 \
+ $(use_enable debug) \
+ $(use_enable geoloc geocode) \
+ $(use_enable geoloc location) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable map) \
+ $(use_enable spell) \
+ $(use_enable v4l gudev) \
+ $(use_with v4l cheese) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ dbus-launch Xemake check #504516
+}
diff --git a/net-im/empathy/files/empathy-3.12.7-Fix-parallel-build-in-extensions.patch b/net-im/empathy/files/empathy-3.12.7-Fix-parallel-build-in-extensions.patch
new file mode 100644
index 000000000000..28eef07fbb3c
--- /dev/null
+++ b/net-im/empathy/files/empathy-3.12.7-Fix-parallel-build-in-extensions.patch
@@ -0,0 +1,65 @@
+From 7af14d9ca148e4d1ec2eb70d7b655bb2fc5a052f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Sun, 30 Nov 2014 22:10:59 +0100
+Subject: [PATCH] Fix parallel build in extensions/
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+GNU Make manual says:
+
+ A rule with multiple targets is equivalent to writing many rules,
+ each with one target, and all identical aside from that.
+
+In other words, make may very well call glib-gtypes-generator.py twice
+(once for each generated header). And hell breaks loose because the
+python code assumes it will run once (it should be using the tempfile
+module, but that's another bug). On a fast multi-core machine, make -j4
+will easily reproduce this bug.
+
+The solution is hidden in the same manual [1] :
+
+ %.tab.c %.tab.h: %.y
+ bison -d $<
+
+ This tells make that the recipe ‘bison -d x.y’ will make both
+ x.tab.c and x.tab.h.
+
+So by using '%' to replace the 'y' in the targets, I'm telling make that
+running the recipe once will generate both files.
+
+[1] http://www.gnu.org/software/make/manual/make.html#Pattern-Examples
+
+https://bugs.gentoo.org/show_bug.cgi?id=515894
+https://bugzilla.gnome.org/show_bug.cgi?id=685837
+
+Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
+---
+ extensions/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/extensions/Makefile.am b/extensions/Makefile.am
+index 79622d4..9082496 100644
+--- a/extensions/Makefile.am
++++ b/extensions/Makefile.am
+@@ -66,7 +66,7 @@ extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl
+ $(tools_dir)/doc-generator.xsl \
+ $< > $@
+
+-_gen/gtypes.h _gen/gtypes-body.h: _gen/all.xml \
++_gen/gt%pes.h _gen/gt%pes-body.h: _gen/all.xml \
+ $(top_srcdir)/tools/glib-gtypes-generator.py
+ $(AM_V_GEN)$(PYTHON) $(top_srcdir)/tools/glib-gtypes-generator.py \
+ $< _gen/gtypes Emp
+@@ -82,7 +82,7 @@ _gen/enums.h: _gen/all.xml \
+ Emp \
+ $< _gen/enums
+
+-_gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
++_gen/int%rfaces-body.h _gen/int%rfaces.h: _gen/all.xml \
+ $(tools_dir)/glib-interfaces-gen.py
+ $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-interfaces-gen.py \
+ Emp _gen/interfaces-body.h _gen/interfaces.h $<
+--
+2.3.6
+
diff --git a/net-im/empathy/metadata.xml b/net-im/empathy/metadata.xml
new file mode 100644
index 000000000000..0968098fd22f
--- /dev/null
+++ b/net-im/empathy/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+ <use>
+ <flag name="geoloc">Enable geolocation support through
+ <pkg>app-misc/geoclue</pkg></flag>
+ <flag name="gnome-online-accounts">Enable using
+ <pkg>net-libs/gnome-online-accounts</pkg> for authorization (e.g.
+ for Google Talk)</flag>
+ <flag name="map">Enable world map support through
+ <pkg>media-libs/libchamplain</pkg></flag>
+ </use>
+ <longdescription>
+ Empathy consists of a rich set of reusable instant messaging widgets,
+ and a GNOME client using those widgets. It uses Telepathy and Nokia's
+ Mission Control. The main goal is to permit desktop integration by
+ providing libempathy and libempathy-gtk libraries. libempathy-gtk is a
+ set of powerful widgets that can be embeded into any GNOME application.
+ A client application is provided.
+ </longdescription>
+</pkgmetadata>