summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centerim/centerim-4.22.10-r1.ebuild131
-rw-r--r--net-im/centerim/files/centerim-4.22.10-system-expat.patch51
2 files changed, 182 insertions, 0 deletions
diff --git a/net-im/centerim/centerim-4.22.10-r1.ebuild b/net-im/centerim/centerim-4.22.10-r1.ebuild
new file mode 100644
index 000000000000..6d7564a0c368
--- /dev/null
+++ b/net-im/centerim/centerim-4.22.10-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils autotools
+
+PROTOCOL_IUSE="+aim gadu +icq +irc +xmpp lj +msn rss +yahoo"
+IUSE="${PROTOCOL_IUSE} bidi nls ssl crypt jpeg otr"
+
+DESCRIPTION="ncurses ICQ/Yahoo!/AIM/IRC/MSN/Jabber/GaduGadu/RSS/LiveJournal Client"
+if [[ ${PV} = *_p* ]] # is this a snaphot?
+then
+ SRC_URI="http://www.centerim.org/download/snapshots/${PN}-${PV/*_p/}.tar.gz"
+elif [[ ${PV} = *.*.*.* ]] # is this a mobshot?
+then
+ SRC_URI="http://www.centerim.org/download/mobshots/${P}.tar.gz"
+else
+ SRC_URI="http://www.centerim.org/download/releases/${P}.tar.gz"
+fi
+HOMEPAGE="http://www.centerim.org/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ dev-libs/expat
+ bidi? ( dev-libs/fribidi )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ jpeg? ( virtual/jpeg )
+ xmpp? (
+ otr? ( <net-libs/libotr-4 )
+ crypt? ( >=app-crypt/gpgme-1.0.2 )
+ )
+ msn? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ yahoo? ( >=net-misc/curl-7.25.0-r1[ssl] )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}"/${P/_p*}
+
+check_protocol_iuse() {
+ local flag
+
+ for flag in ${PROTOCOL_IUSE}
+ do
+ use ${flag#+} && return 0
+ done
+
+ return 1
+}
+
+pkg_setup() {
+ if ! check_protocol_iuse
+ then
+ eerror
+ eerror "Please activate at least one of the following protocol USE flags:"
+ eerror "${PROTOCOL_IUSE//+}"
+ eerror
+ die "Please activate at least one protocol USE flag!"
+ fi
+
+ if use otr && ! use xmpp
+ then
+ ewarn
+ ewarn "Support for OTR is only supported with Jabber!"
+ ewarn
+ fi
+
+ if use gadu && ! use jpeg
+ then
+ ewarn
+ ewarn "You need jpeg support to be able to register Gadu-Gadu accounts!"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ (
+ cd libjabber/ || exit 1
+ rm \
+ asciitab.h \
+ hashtable.[ch] \
+ iasciitab.h \
+ latin1tab.h \
+ utf8tab.h \
+ xmldef.h \
+ xmlparse.[ch] \
+ xmlrole.[ch] \
+ xmltok.[ch] \
+ xmltok_impl_c.h \
+ xmltok_impl.h \
+ ) || die
+ epatch "${FILESDIR}"/${P}-system-expat.patch
+ eautoreconf
+
+ # Don't execute git commands, bug #228151
+ cat >"${S}"/misc/git-version-gen <<-EOF
+ #!/bin/sh
+ echo -n "${PVR}"
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl) \
+ $(use_enable aim) \
+ $(use_with bidi fribidi) \
+ $(use_with jpeg libjpeg) \
+ $(use_with otr libotr) \
+ $(use_enable gadu gg) \
+ $(use_enable icq) \
+ $(use_enable irc) \
+ $(use_enable xmpp jabber) \
+ $(use_enable lj) \
+ $(use_enable msn) \
+ $(use_enable nls locales-fix) \
+ $(use_enable nls) \
+ $(use_enable rss) \
+ $(use_enable yahoo) \
+ || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog FAQ README THANKS TODO
+}
diff --git a/net-im/centerim/files/centerim-4.22.10-system-expat.patch b/net-im/centerim/files/centerim-4.22.10-system-expat.patch
new file mode 100644
index 000000000000..ef3d52c28c3d
--- /dev/null
+++ b/net-im/centerim/files/centerim-4.22.10-system-expat.patch
@@ -0,0 +1,51 @@
+From 539f0dd1b9b81c4b0aece3ab076b1c75073c8062 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Fri, 6 May 2016 02:33:51 +0200
+Subject: [PATCH] Build against system Expat
+
+---
+ libjabber/Makefile.am | 4 ++--
+ libjabber/libxode.h | 2 +-
+ src/Makefile.am | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/libjabber/Makefile.am b/libjabber/Makefile.am
+index f91ad8f..7b20f6b 100644
+--- a/libjabber/Makefile.am
++++ b/libjabber/Makefile.am
+@@ -1,4 +1,4 @@
+ AM_CPPFLAGS = -I$(top_srcdir)/connwrap
+ noinst_LIBRARIES = liblibjabber.a
+-noinst_HEADERS = xmltok_impl_c.h latin1tab.h log.h asciitab.h libxode.h jabber.h hashtable.h xmlparse.h iasciitab.h xmldef.h xmltok.h utf8tab.h xmltok_impl.h xmlrole.h nametab.h xmltok_ns_c.h
+-liblibjabber_a_SOURCES = jid.c log.c jutil.c str.c expat.c hashtable.c genhash.c pproxy.c pool.c rate.c xmlparse.c xstream.c xmltok.c xmlnode.c jconn.c xmlrole.c jpacket.c snprintf.c socket.c sha.c
++noinst_HEADERS = log.h libxode.h jabber.h nametab.h
++liblibjabber_a_SOURCES = jid.c log.c jutil.c str.c expat.c genhash.c pproxy.c pool.c rate.c xstream.c xmlnode.c jconn.c jpacket.c snprintf.c socket.c sha.c
+diff --git a/libjabber/libxode.h b/libjabber/libxode.h
+index d6c92a6..8752b0c 100644
+--- a/libjabber/libxode.h
++++ b/libjabber/libxode.h
+@@ -16,7 +16,7 @@
+ #include <arpa/inet.h>
+ #include <sys/time.h>
+
+-#include "xmlparse.h"
++#include <expat.h>
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3a0feaf..b8cf2ff 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -22,7 +22,7 @@ centerim_LDADD += -llibgadu
+ endif
+ if BUILD_JABBER
+ centerim_LDFLAGS += -L$(top_builddir)/libjabber
+-centerim_LDADD += -llibjabber
++centerim_LDADD += -llibjabber -lexpat
+ endif
+ if BUILD_MSN
+ centerim_LDFLAGS += -L$(top_builddir)/libmsn
+--
+2.8.1
+