summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/files/telegram-desktop-qt5.15.patch23
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.1.0.ebuild5
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.1.7.ebuild4
3 files changed, 31 insertions, 1 deletions
diff --git a/net-im/telegram-desktop/files/telegram-desktop-qt5.15.patch b/net-im/telegram-desktop/files/telegram-desktop-qt5.15.patch
new file mode 100644
index 000000000000..80c02b10db2b
--- /dev/null
+++ b/net-im/telegram-desktop/files/telegram-desktop-qt5.15.patch
@@ -0,0 +1,23 @@
+diff -ru tdesktop-2.1.7-full.orig/Telegram/lib_ui/ui/effects/animation_value.h tdesktop-2.1.7-full/Telegram/lib_ui/ui/effects/animation_value.h
+--- tdesktop-2.1.7-full.orig/Telegram/lib_ui/ui/effects/animation_value.h 2020-05-24 09:44:41.000000000 +0200
++++ tdesktop-2.1.7-full/Telegram/lib_ui/ui/effects/animation_value.h 2020-05-26 20:31:34.381796057 +0200
+@@ -10,6 +10,8 @@
+
+ #include "ui/style/style_core.h"
+
++#include <QPainterPath>
++
+ namespace anim {
+
+ enum class type {
+diff -ru tdesktop-2.1.7-full.orig/Telegram/lib_ui/ui/effects/cross_animation.cpp tdesktop-2.1.7-full/Telegram/lib_ui/ui/effects/cross_animation.cpp
+--- tdesktop-2.1.7-full.orig/Telegram/lib_ui/ui/effects/cross_animation.cpp 2020-05-24 09:44:41.000000000 +0200
++++ tdesktop-2.1.7-full/Telegram/lib_ui/ui/effects/cross_animation.cpp 2020-05-26 20:32:16.340015129 +0200
+@@ -10,6 +10,7 @@
+ #include "ui/painter.h"
+
+ #include <QtCore/QtMath>
++#include <QPainterPath>
+
+ namespace Ui {
+ namespace {
diff --git a/net-im/telegram-desktop/telegram-desktop-2.1.0.ebuild b/net-im/telegram-desktop/telegram-desktop-2.1.0.ebuild
index 07c9b19ab458..dd038756cdd2 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.1.0.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.1.0.ebuild
@@ -70,7 +70,10 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}/${PV}-kde-dir.patch" )
+PATCHES=(
+ "${FILESDIR}/${PV}-kde-dir.patch"
+ "${FILESDIR}/${PN}-qt5.15.patch"
+)
src_configure() {
local mycxxflags=(
diff --git a/net-im/telegram-desktop/telegram-desktop-2.1.7.ebuild b/net-im/telegram-desktop/telegram-desktop-2.1.7.ebuild
index 3206772347bb..e031bf3e1e77 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.1.7.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.1.7.ebuild
@@ -69,6 +69,10 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}/${PN}-qt5.15.patch"
+)
+
pkg_pretend() {
if has ccache ${FEATURES}; then
ewarn