summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/konversation')
-rw-r--r--net-irc/konversation/files/konversationrc24
-rw-r--r--net-irc/konversation/konversation-1.6.2.ebuild10
-rw-r--r--net-irc/konversation/konversation-1.7.ebuild8
3 files changed, 41 insertions, 1 deletions
diff --git a/net-irc/konversation/files/konversationrc b/net-irc/konversation/files/konversationrc
new file mode 100644
index 000000000000..932374b6bf45
--- /dev/null
+++ b/net-irc/konversation/files/konversationrc
@@ -0,0 +1,24 @@
+[Channel 0]
+Name=#gentoo
+
+[Channel 1]
+Name=#gentoo-desktop
+
+[Channel 2]
+Name=#gentoo-kde
+
+[Channel 3]
+Name=#gentoo-xfce
+
+[Server 0]
+Port=8001
+SSLEnabled=false
+Server=chat.freenode.net
+
+[ServerGroup 0]
+AutoConnect=false
+AutoJoinChannels=Channel 0,Channel 1,Channel 2,Channel 3
+EnableNotifications=true
+Expanded=false
+Name=Freenode
+ServerList=Server 0
diff --git a/net-irc/konversation/konversation-1.6.2.ebuild b/net-irc/konversation/konversation-1.6.2.ebuild
index 8eaa85aa7bc6..2ce37c414759 100644
--- a/net-irc/konversation/konversation-1.6.2.ebuild
+++ b/net-irc/konversation/konversation-1.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -63,3 +63,11 @@ src_configure() {
kde5_src_configure
}
+
+src_install() {
+ kde5_src_install
+
+ # Bug 616162
+ insinto /etc/xdg
+ doins "${FILESDIR}"/konversationrc
+}
diff --git a/net-irc/konversation/konversation-1.7.ebuild b/net-irc/konversation/konversation-1.7.ebuild
index 41abe5502ae6..e41f158e7e78 100644
--- a/net-irc/konversation/konversation-1.7.ebuild
+++ b/net-irc/konversation/konversation-1.7.ebuild
@@ -63,3 +63,11 @@ src_configure() {
kde5_src_configure
}
+
+src_install() {
+ kde5_src_install
+
+ # Bug 616162
+ insinto /etc/xdg
+ doins "${FILESDIR}"/konversationrc
+}