summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index b35c166c0a0d..ee382d60463e 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{4,5,6,7} )
inherit gnome2-utils meson mono-env python-single-r1 xdg-utils
@@ -83,9 +83,10 @@ src_configure() {
-Dwith-checksum="$(usex plugin-checksum true false)"
-Dwith-fishlim="$(usex plugin-fishlim true false)"
-Dwith-lua="$(usex lua lua false)"
- -Dwith-perl="$(usex perl true false)"
+ -Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
-Dwith-python="$(usex python "${EPYTHON/.*}" false)"
-Dwith-sysinfo="$(usex plugin-sysinfo true false)"
+ -Dwith-appdata=false
)
meson_src_configure
}