summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.18.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.18.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.18.ebuild b/net-libs/libhtp/libhtp-0.5.18.ebuild
new file mode 100644
index 000000000000..2c11b3bb98ed
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib-minimal
+
+MY_P=${P#lib}
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}