summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-0.7.4.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-0.7.4.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.7.4.ebuild b/net-libs/qxmpp/qxmpp-0.7.4.ebuild
deleted file mode 100644
index 76d40d7c4f9e..000000000000
--- a/net-libs/qxmpp/qxmpp-0.7.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit qt4-r2 multilib
-
-DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
-HOMEPAGE="https://code.google.com/p/qxmpp/"
-SRC_URI="https://qxmpp.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="debug doc test"
-
-RDEPEND="dev-qt/qtcore:4
- dev-qt/qtgui:4
- media-libs/speex"
-DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:4 )"
-
-src_prepare(){
- if ! use doc; then
- sed -i \
- -e '/SUBDIRS/s/doc//' \
- -e '/INSTALLS/d' \
- qxmpp.pro || die "sed for removing docs failed"
- fi
- if ! use test; then
- sed -i -e '/SUBDIRS/s/tests//' \
- qxmpp.pro || die "sed for removing tests failed"
- fi
- qt4-r2_src_prepare
-}
-
-src_configure(){
- eqmake4 "${S}"/qxmpp.pro "PREFIX=${EPREFIX}/usr" "LIBDIR=$(get_libdir)"
-}
-
-src_install() {
- qt4-r2_src_install
- if use doc; then
- # Use proper path for documentation
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${P} || die "doc mv failed"
- fi
-}