summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/nextcloud-client')
-rw-r--r--net-misc/nextcloud-client/nextcloud-client-3.8.2-r1.ebuild8
-rw-r--r--net-misc/nextcloud-client/nextcloud-client-3.9.1.ebuild8
-rw-r--r--net-misc/nextcloud-client/nextcloud-client-3.9.4.ebuild8
3 files changed, 15 insertions, 9 deletions
diff --git a/net-misc/nextcloud-client/nextcloud-client-3.8.2-r1.ebuild b/net-misc/nextcloud-client/nextcloud-client-3.8.2-r1.ebuild
index 982596d05a8f..23b5a83aabf2 100644
--- a/net-misc/nextcloud-client/nextcloud-client-3.8.2-r1.ebuild
+++ b/net-misc/nextcloud-client/nextcloud-client-3.8.2-r1.ebuild
@@ -106,8 +106,10 @@ src_compile() {
pkg_postinst() {
xdg_pkg_postinst
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
+ if ! has_version -r "dev-libs/qtkeychain[keyring]"; then
+ elog "dev-libs/qtkeychain has not been build with the 'keyring' USE flag."
+ elog "Please consider enabling the 'keyring' USE flag. Otherwise you may"
+ elog "have to authenticate manually every time you start the nextlcoud client."
+ elog "See https://bugs.gentoo.org/912844 for more information."
fi
}
diff --git a/net-misc/nextcloud-client/nextcloud-client-3.9.1.ebuild b/net-misc/nextcloud-client/nextcloud-client-3.9.1.ebuild
index 982596d05a8f..23b5a83aabf2 100644
--- a/net-misc/nextcloud-client/nextcloud-client-3.9.1.ebuild
+++ b/net-misc/nextcloud-client/nextcloud-client-3.9.1.ebuild
@@ -106,8 +106,10 @@ src_compile() {
pkg_postinst() {
xdg_pkg_postinst
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
+ if ! has_version -r "dev-libs/qtkeychain[keyring]"; then
+ elog "dev-libs/qtkeychain has not been build with the 'keyring' USE flag."
+ elog "Please consider enabling the 'keyring' USE flag. Otherwise you may"
+ elog "have to authenticate manually every time you start the nextlcoud client."
+ elog "See https://bugs.gentoo.org/912844 for more information."
fi
}
diff --git a/net-misc/nextcloud-client/nextcloud-client-3.9.4.ebuild b/net-misc/nextcloud-client/nextcloud-client-3.9.4.ebuild
index 78bd99d7580a..94cff32e49fb 100644
--- a/net-misc/nextcloud-client/nextcloud-client-3.9.4.ebuild
+++ b/net-misc/nextcloud-client/nextcloud-client-3.9.4.ebuild
@@ -106,8 +106,10 @@ src_compile() {
pkg_postinst() {
xdg_pkg_postinst
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
+ if ! has_version -r "dev-libs/qtkeychain[keyring]"; then
+ elog "dev-libs/qtkeychain has not been build with the 'keyring' USE flag."
+ elog "Please consider enabling the 'keyring' USE flag. Otherwise you may"
+ elog "have to authenticate manually every time you start the nextlcoud client."
+ elog "See https://bugs.gentoo.org/912844 for more information."
fi
}