summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/omniORB-4.1.4-r2.ebuild6
-rw-r--r--net-misc/omniORB/omniORB-4.2.1_p2.ebuild5
2 files changed, 7 insertions, 4 deletions
diff --git a/net-misc/omniORB/omniORB-4.1.4-r2.ebuild b/net-misc/omniORB/omniORB-4.1.4-r2.ebuild
index 2bfee4a92dbd..183a5713a85a 100644
--- a/net-misc/omniORB/omniORB-4.1.4-r2.ebuild
+++ b/net-misc/omniORB/omniORB-4.1.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,8 +15,10 @@ LICENSE="LGPL-2 GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86"
IUSE="doc ssl static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b:0= )"
+RDEPEND="${PYTHON_DEPS}
+ ssl? ( >=dev-libs/openssl-0.9.6b:0= )"
DEPEND="${RDEPEND}"
src_prepare() {
diff --git a/net-misc/omniORB/omniORB-4.2.1_p2.ebuild b/net-misc/omniORB/omniORB-4.2.1_p2.ebuild
index 58eac9fcd833..46b2de01bec8 100644
--- a/net-misc/omniORB/omniORB-4.2.1_p2.ebuild
+++ b/net-misc/omniORB/omniORB-4.2.1_p2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,8 +9,8 @@ EAPI=6
# highest version the configure script will accept is python-3.3, but
# that's on it's way out, so we prefer to stick with python-2.7 for now.
PYTHON_COMPAT=( python2_7 )
+
inherit python-single-r1
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
MY_P="${P/_p/-}"
DESCRIPTION="A robust, high-performance CORBA 2 ORB"
@@ -21,6 +21,7 @@ LICENSE="LGPL-2 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc ipv6 ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
ssl? ( dev-libs/openssl:0= )"