summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/amphetadesk')
-rw-r--r--net-news/amphetadesk/Manifest1
-rw-r--r--net-news/amphetadesk/amphetadesk-0.93.1.ebuild40
-rw-r--r--net-news/amphetadesk/files/amphetadesk.initd15
-rw-r--r--net-news/amphetadesk/metadata.xml10
4 files changed, 66 insertions, 0 deletions
diff --git a/net-news/amphetadesk/Manifest b/net-news/amphetadesk/Manifest
new file mode 100644
index 000000000000..66936f47c4f0
--- /dev/null
+++ b/net-news/amphetadesk/Manifest
@@ -0,0 +1 @@
+DIST amphetadesk-src-v0.93.1.tar.gz 853503 SHA256 c9a900304dc8aa64eeca777adbd960ff5a486d25eb321727fc3b2508d5eb4f6e SHA512 10e6c1b0227872c064a090aa72f95e7fe57b0f6cf71f8c31935c12fde4d127636eeea4f148218ebbc4a08ee4b4f653c793264cf8102e1d070d3b4c6a2e7c7793 WHIRLPOOL ca2b1392c9c727ba427ee34f50df0b9b21c264dfd1e96192f14c13758685aaafcad111a528ed58aed868afeba41d11665079db2032b04cb81d100b62c7cd1cb5
diff --git a/net-news/amphetadesk/amphetadesk-0.93.1.ebuild b/net-news/amphetadesk/amphetadesk-0.93.1.ebuild
new file mode 100644
index 000000000000..5504f7efbcbe
--- /dev/null
+++ b/net-news/amphetadesk/amphetadesk-0.93.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="AmphetaDesk is a free syndicated news aggregator"
+HOMEPAGE="http://www.disobey.com/amphetadesk/"
+SRC_URI="mirror://sourceforge/sourceforge/amphetadesk/${PN}-src-v${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+DEPEND="dev-lang/perl
+ dev-perl/libwww-perl
+ dev-libs/expat
+ dev-perl/XML-Parser
+ virtual/perl-IO-Compress"
+S=${WORKDIR}/${PN}-src-v${PV}
+
+src_install() {
+ dodir /usr/share/amphetadesk
+ cp "${S}"/AmphetaDesk.pl "${D}"/usr/share/amphetadesk/AmphetaDesk.pl
+ dodoc README.txt
+ cp -R "${S}"/data "${D}"/usr/share/amphetadesk
+ cp -R "${S}"/docs "${D}"/usr/share/amphetadesk
+ cp -R "${S}"/lib "${D}"/usr/share/amphetadesk
+ cp -R "${S}"/templates "${D}"/usr/share/amphetadesk
+ newinitd "${FILESDIR}"/amphetadesk.initd amphetadesk
+}
+
+pkg_postinst() {
+ # fixes bug #25066 thanks to kloeri
+ /etc/init.d/depscan.sh
+
+ einfo "AmphetaDesk should be started and stopped with the runscript located at "
+ einfo "'/etc/init.d/amphetadesk'. You can access AmphetaDesk after it has been"
+ einfo "started in your browser of choice on port 8888."
+ einfo ""
+ ewarn "If you start AmphetaDesk at boot with rc-update don't give it a browser"
+ ewarn "to start up when it loads (in the options page)"
+}
diff --git a/net-news/amphetadesk/files/amphetadesk.initd b/net-news/amphetadesk/files/amphetadesk.initd
new file mode 100644
index 000000000000..288a11bc1ea6
--- /dev/null
+++ b/net-news/amphetadesk/files/amphetadesk.initd
@@ -0,0 +1,15 @@
+#!/sbin/runscript
+
+start() {
+ ebegin "Starting AmphetaDesk"
+ cd /usr/share/amphetadesk
+ ./AmphetaDesk.pl > /dev/null &
+ eend 0
+}
+
+stop() {
+ ebegin "Stoping AmphetaDesk"
+ killall AmphetaDesk.pl
+ eend 0
+}
+
diff --git a/net-news/amphetadesk/metadata.xml b/net-news/amphetadesk/metadata.xml
new file mode 100644
index 000000000000..884718283c4a
--- /dev/null
+++ b/net-news/amphetadesk/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sourceforge</remote-id>
+ </upstream>
+</pkgmetadata>