summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/canto-daemon')
-rw-r--r--net-news/canto-daemon/Manifest1
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.1.ebuild28
-rw-r--r--net-news/canto-daemon/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/net-news/canto-daemon/Manifest b/net-news/canto-daemon/Manifest
new file mode 100644
index 000000000000..30584577e5f9
--- /dev/null
+++ b/net-news/canto-daemon/Manifest
@@ -0,0 +1 @@
+DIST canto-daemon-0.9.1.tar.gz 49316 SHA256 7eff52315a921d29944be4ba6fcadca1b4757ee940f567e44403e08029dbf333 SHA512 88e708c92813ddda44a8ea6a5d21722510822f22ebc0a4fb4165e6793ea50d89b139a51a4b1e06f811d7073c6b103590b52e4299c674f904e8b5aae7645484fd WHIRLPOOL 6646712a2e106c9a74cb37bde87653ad836cc075897a0f5707bcf2c78cbd348d5955527cc4bdff52813835ef69d5d4114ef334c8537ea477b7e0d8a4dfeb67b1
diff --git a/net-news/canto-daemon/canto-daemon-0.9.1.ebuild b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
new file mode 100644
index 000000000000..72f0eb8521b5
--- /dev/null
+++ b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_REQ_USE="xml(+),threads(+)"
+inherit distutils-r1 multilib
+
+DESCRIPTION="Daemon part of Canto-NG RSS reader"
+HOMEPAGE="http://codezen.org/canto-ng/"
+SRC_URI="http://codezen.org/static/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/canto-next-${PV}"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/net-news/canto-daemon/metadata.xml b/net-news/canto-daemon/metadata.xml
new file mode 100644
index 000000000000..9a8bf0994f64
--- /dev/null
+++ b/net-news/canto-daemon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">themoken/canto-next</remote-id>
+ </upstream>
+</pkgmetadata>