summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/rawdog/rawdog-2.19.ebuild')
-rw-r--r--net-news/rawdog/rawdog-2.19.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-news/rawdog/rawdog-2.19.ebuild b/net-news/rawdog/rawdog-2.19.ebuild
new file mode 100644
index 000000000000..76b81fb7aa18
--- /dev/null
+++ b/net-news/rawdog/rawdog-2.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rawdog - RSS Aggregator Without Delusions Of Grandeur"
+HOMEPAGE="http://offog.org/code/rawdog.html http://pypi.python.org/pypi/rawdog"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ~s390 sparc x86"
+IUSE=""
+
+DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RDEPEND=""
+# Test run fails under multi threading
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_test() {
+ # pypy fails half way through; meh
+ ./test-rawdog || die "Test run aborted"
+}