summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/snownews')
-rw-r--r--net-news/snownews/Manifest1
-rw-r--r--net-news/snownews/files/snownews-1.5.7-stdint.patch17
-rw-r--r--net-news/snownews/metadata.xml7
-rw-r--r--net-news/snownews/snownews-1.5.12-r1.ebuild61
4 files changed, 86 insertions, 0 deletions
diff --git a/net-news/snownews/Manifest b/net-news/snownews/Manifest
new file mode 100644
index 000000000000..a6b2be8fe034
--- /dev/null
+++ b/net-news/snownews/Manifest
@@ -0,0 +1 @@
+DIST snownews-1.5.12.tar.gz 167944 SHA256 26dd96e9345d9cbc1c0c9470417080dd0c3eb31e7ea944f78f3302d7060ecb90 SHA512 7a7ccd5ea57f8bbb73f1429ab931a38203e858c74a383c5347e66088b84f6a7240feeee99e179687ce0a7a89c6c1406ce20d6c5d6771d25a0a0301fa5526e220 WHIRLPOOL c0a127db3700789e134720cbf77858a7c37950e9b05b4ca2f13372f774eb6f7ee97dd2f957ba1c3571c241a241993feb702dbb0d90c0c8ea03d2e6003fdf24b1
diff --git a/net-news/snownews/files/snownews-1.5.7-stdint.patch b/net-news/snownews/files/snownews-1.5.7-stdint.patch
new file mode 100644
index 000000000000..f6c81e79925a
--- /dev/null
+++ b/net-news/snownews/files/snownews-1.5.7-stdint.patch
@@ -0,0 +1,17 @@
+diff -ru snownews-1.5.7~/md5.h snownews-1.5.7/md5.h
+--- snownews-1.5.7~/md5.h 2006-12-03 16:36:54.000000000 +0100
++++ snownews-1.5.7/md5.h 2006-12-03 16:47:23.000000000 +0100
+@@ -31,11 +31,8 @@
+ #ifndef MD5_H
+ #define MD5_H
+
+-#ifdef __alpha
+-typedef unsigned int uint32;
+-#else
+-typedef unsigned long uint32;
+-#endif
++#include <stdint.h>
++typedef uint32_t uint32;
+
+ struct MD5Context {
+ uint32 buf[4];
diff --git a/net-news/snownews/metadata.xml b/net-news/snownews/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/net-news/snownews/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-news/snownews/snownews-1.5.12-r1.ebuild b/net-news/snownews/snownews-1.5.12-r1.ebuild
new file mode 100644
index 000000000000..173be8a21d2b
--- /dev/null
+++ b/net-news/snownews/snownews-1.5.12-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
+HOMEPAGE="http://snownews.kcore.de/"
+SRC_URI="http://home.kcore.de/~kiza/software/snownews/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="unicode"
+
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.6
+ >=sys-libs/ncurses-5.3[unicode?]
+ dev-libs/openssl
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-perl/XML-LibXML
+ dev-perl/libwww-perl
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s|-O2||g" configure || die
+ sed -i -e 's|$(INSTALL) -s|$(INSTALL)|g' Makefile || die
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ if use unicode; then
+ sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncursesw`|' configure || die
+ else
+ sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncurses`|' configure || die
+ fi
+
+ # perl script, not autotools based
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ EXTRA_CFLAGS="${CFLAGS}" \
+ EXTRA_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+
+ dodoc AUTHOR Changelog CREDITS README README.de README.patching
+}