summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/yencode/yencode-0.46.ebuild')
-rw-r--r--net-news/yencode/yencode-0.46.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-news/yencode/yencode-0.46.ebuild b/net-news/yencode/yencode-0.46.ebuild
new file mode 100644
index 000000000000..f00ecb814b9c
--- /dev/null
+++ b/net-news/yencode/yencode-0.46.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="yEnc encoder/decoder package"
+HOMEPAGE="http://www.yencode.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc arm ~amd64"
+IUSE="nls"
+
+DEPEND=""
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc AUTHORS NEWS README ChangeLog
+ doman doc/ydecode.1 doc/yencode.1 doc/ypost.1 doc/ypostrc.5
+}