summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
index 24631e72b86e..7316bdc01781 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ default
+
+ # bug 641382
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 24631e72b86e..26971a131175 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ default
+
+ # bug 641382
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON