summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/squirm/files/squirm-1.26-gentoo.patch')
-rw-r--r--net-proxy/squirm/files/squirm-1.26-gentoo.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-proxy/squirm/files/squirm-1.26-gentoo.patch b/net-proxy/squirm/files/squirm-1.26-gentoo.patch
new file mode 100644
index 000000000000..16b6e21c7aa2
--- /dev/null
+++ b/net-proxy/squirm/files/squirm-1.26-gentoo.patch
@@ -0,0 +1,34 @@
+diff -Nru squirm-1.26.orig/Makefile squirm-1.26/Makefile
+--- squirm-1.26.orig/Makefile 2005-08-19 09:31:06.000000000 +0200
++++ squirm-1.26/Makefile 2009-06-20 14:58:18.000000000 +0200
+@@ -1,7 +1,7 @@
+ # $Id$
+
+ # The path to install squirm under
+-PREFIX=/usr/local/squirm
++PREFIX=/opt/squirm
+
+ # The username that squid runs as (see cache_effective_user in squid.conf)
+ USER=squid
+@@ -29,10 +29,10 @@
+ CC=gcc
+
+
+-OPTIMISATION=-O3
++OPTIMISATION=
+ BINARIES = squirm
+
+-CFLAGS = -O3 -Wall -funroll-loops -DPREFIX=\"$(PREFIX)\"
++CFLAGS += -DPREFIX=\"$(PREFIX)\"
+ #CFLAGS = -Wall -g -DPREFIX=\"$(PREFIX)\"
+ #CFLAGS = -Wall -g -DDEBUG
+
+@@ -45,7 +45,7 @@
+ install -m 750 -o $(USER) -g $(GROUP) -d $(PREFIX)/logs
+ install -m 660 -c -o root -g $(GROUP) squirm.conf.dist squirm.patterns.dist \
+ $(PREFIX)/etc
+- install -m 755 -o root -g $(ROOT_GROUP) --strip squirm $(PREFIX)/bin
++ install -m 755 -o root -g $(ROOT_GROUP) squirm $(PREFIX)/bin
+
+ squirm.o: squirm.c $(HFILES)
+ $(CC) -c squirm.c $(CFLAGS)