summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/haproxy-2.2.25.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.2.29.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-2.2.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.4.18.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.4.22.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-2.4.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.6.9.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-2.6.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.7.3.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-2.7.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild9
11 files changed, 73 insertions, 18 deletions
diff --git a/net-proxy/haproxy/haproxy-2.2.25.ebuild b/net-proxy/haproxy/haproxy-2.2.25.ebuild
index 93008743019c..dc5155b408da 100644
--- a/net-proxy/haproxy/haproxy-2.2.25.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -75,12 +75,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.2.29.ebuild b/net-proxy/haproxy/haproxy-2.2.29.ebuild
index 5a6ecbd9677d..752bdc4828b3 100644
--- a/net-proxy/haproxy/haproxy-2.2.29.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.29.ebuild
@@ -75,12 +75,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.2.9999.ebuild b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
index 2bf20bf3ac64..752bdc4828b3 100644
--- a/net-proxy/haproxy/haproxy-2.2.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -75,12 +75,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.4.18.ebuild b/net-proxy/haproxy/haproxy-2.4.18.ebuild
index a0008b4be30c..883ab8118c3f 100644
--- a/net-proxy/haproxy/haproxy-2.4.18.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.4.22.ebuild b/net-proxy/haproxy/haproxy-2.4.22.ebuild
index 1dc2f69b3bad..a4d1fb37c08b 100644
--- a/net-proxy/haproxy/haproxy-2.4.22.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.22.ebuild
@@ -71,12 +71,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.4.9999.ebuild b/net-proxy/haproxy/haproxy-2.4.9999.ebuild
index ab90e472bdf0..ff2118770d3f 100644
--- a/net-proxy/haproxy/haproxy-2.4.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.6.9.ebuild b/net-proxy/haproxy/haproxy-2.6.9.ebuild
index 83227697a6a5..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-2.6.9.ebuild
+++ b/net-proxy/haproxy/haproxy-2.6.9.ebuild
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.6.9999.ebuild b/net-proxy/haproxy/haproxy-2.6.9999.ebuild
index fd42fd4cb085..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-2.6.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.7.3.ebuild b/net-proxy/haproxy/haproxy-2.7.3.ebuild
index 83227697a6a5..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-2.7.3.ebuild
+++ b/net-proxy/haproxy/haproxy-2.7.3.ebuild
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-2.7.9999.ebuild b/net-proxy/haproxy/haproxy-2.7.9999.ebuild
index fd42fd4cb085..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-2.7.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.7.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
index fd42fd4cb085..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )