summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/erfa/erfa-1.4.0.ebuild')
-rw-r--r--sci-astronomy/erfa/erfa-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-astronomy/erfa/erfa-1.4.0.ebuild b/sci-astronomy/erfa/erfa-1.4.0.ebuild
new file mode 100644
index 000000000000..6a721cbc58f4
--- /dev/null
+++ b/sci-astronomy/erfa/erfa-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Essential Routines for Fundamental Astronomy"
+HOMEPAGE="https://github.com/liberfa/erfa"
+SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}