summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.14-r1.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index fe2bbb0dfa1c..54718b48ff6b 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,2 +1 @@
-DIST units-2.14.tar.gz 1177024 BLAKE2B e129e018e79e60eb3bd8f5c1afa693021ea7c4bfaa330fd0fc94046a5defc5d6f52faeb38b898cc95a7b6626fc6e97f5091d84c7c310842b68dc7f1b4b6c781d SHA512 3cd09a76fb1cccbafaa3e023c791740738c8347425b2645cad1fa768dee3ebde917602cf65988ee8922fed512ec0bc2367f68545450789fc6bf1a79f066a6986
DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf6bafbea5f8b4972eca0acb13adfb4b2bc70ef0a3df747ee31084076fea3d3199922f0c44fc8c6d08232192b SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091
diff --git a/sci-calculators/units/units-2.14-r1.ebuild b/sci-calculators/units/units-2.14-r1.ebuild
deleted file mode 100644
index 45559228bae3..000000000000
--- a/sci-calculators/units/units-2.14-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE="xml"
-inherit eutils python-single-r1
-
-DESCRIPTION="Unit conversion program"
-HOMEPAGE="https://www.gnu.org/software/units/units.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="FDL-1.3 GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- sys-libs/readline:=
- units_cur? (
- dev-python/unidecode[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-DEPEND=${RDEPEND}
-
-pkg_setup() {
- use units_cur && python-single-r1_pkg_setup
-}
-
-src_configure() {
- econf ac_cv_path_PYTHON=no
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc ChangeLog NEWS README
-
- # we're intentionally delaying this since 'make install' would
- # get confused if we shove 'units_cur' there, and there is no real
- # need to add more complexity for it
- if use units_cur; then
- local pyver
- python_is_python3 && pyver=3 || pyver=2
- sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
- "units_cur${pyver}" > units_cur || die
- python_doscript units_cur
- fi
-}