summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.13.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index a499ad5f7548..9b34f6f4656d 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1 +1,2 @@
DIST units-2.12.tar.gz 875884 SHA256 7868ea5118f1fe8e9f9f7256ecc7f1ee0dd7027ba9f32cc739184af1ed94bbcb SHA512 90065c03ecc2cb821b8a8c5bd2c6b577ea35aef7c26de83d066b216f5aa9cf071f0fcb57edff24f83b538690a98a57c1a8677a8e06d8a4a8286c84cd02a336ac WHIRLPOOL 179155bc8b97ed2c7f27c5e640bcb7d1d5820dc554f3ea66f411f27af856c79709e4694c4981c8da58a9f3d0c4dd5cca087fbf1c85ef3ed7d4783f61b75f8d05
+DIST units-2.13.tar.gz 1170233 SHA256 0ba5403111f8e5ea22be7d51ab74c8ccb576dc30ddfbf18a46cb51f9139790ab SHA512 39b380480ab6f48e56a7f122bb66f53ec49667f5ae3479a128536c58d29b1a1bfe281374f06911e8f713fe21459f57d13974c3629180b22968761cad15b10de2 WHIRLPOOL f1a4f85483e2cc9b4d2112a8ed36f51de7efc09b0ab6da926282d474615441f0196697d459cadb13aed1e5fa586261f7c45af2cc980be04b0fc810c57a7acb3e
diff --git a/sci-calculators/units/units-2.13.ebuild b/sci-calculators/units/units-2.13.ebuild
new file mode 100644
index 000000000000..1726de6848b7
--- /dev/null
+++ b/sci-calculators/units/units-2.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+inherit eutils python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+
+DEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ dev-lang/python-exec:2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ units_cur? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+
+units_cur_prepare() {
+ local UNITS_PYTHON_MAJOR
+ UNITS_PYTHON_MAJOR=$(
+ UNITS_PYTHON_MAJOR=${EPYTHON/.*}
+ shopt -s extglob
+ echo ${UNITS_PYTHON_MAJOR/*([[:alpha:]])}
+ )
+ sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" units_cur${UNITS_PYTHON_MAJOR} > units_cur-${EPYTHON}
+}
+
+src_prepare() {
+ use units_cur && python_foreach_impl units_cur_prepare
+}
+
+src_compile() {
+ emake HAVE_PYTHON=no
+}
+
+units_cur_install() {
+ python_newexe units_cur-${EPYTHON} units_cur
+}
+
+src_install() {
+ emake DESTDIR="${D}" HAVE_PYTHON=no install
+
+ dodoc ChangeLog NEWS README
+
+ use units_cur && python_foreach_impl units_cur_install
+}