summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.20.ebuild11
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild11
2 files changed, 6 insertions, 16 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.20.ebuild b/sci-geosciences/gpsd/gpsd-3.20.ebuild
index 5b207643d5d7..22ad7bf0704c 100644
--- a/sci-geosciences/gpsd/gpsd-3.20.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.20.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7,8} )
SCONS_MIN_VERSION="2.3.0"
-inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
+inherit eutils udev multilib distutils-r1 scons-utils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -41,6 +41,7 @@ REQUIRED_USE="X? ( python )
RESTRICT="!test? ( test )"
RDEPEND="
+ acct-user/gpsd
>=net-misc/pps-tools-0.0.20120407
bluetooth? ( net-wireless/bluez )
dbus? (
@@ -131,7 +132,7 @@ src_configure() {
rundir="/run"
chrpath=False
gpsd_user=gpsd
- gpsd_group=uucp
+ gpsd_group=dialout
nostrip=True
manbuild=False
shared=$(usex !static True False)
@@ -186,9 +187,3 @@ src_install() {
use python && distutils-r1_src_install
}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 73c52f149eb1..f0fcb09fdae8 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7,8} )
SCONS_MIN_VERSION="2.3.0"
-inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
+inherit eutils udev multilib distutils-r1 scons-utils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -41,6 +41,7 @@ REQUIRED_USE="X? ( python )
RESTRICT="!test? ( test )"
RDEPEND="
+ acct-user/gpsd
>=net-misc/pps-tools-0.0.20120407
bluetooth? ( net-wireless/bluez )
dbus? (
@@ -135,7 +136,7 @@ src_configure() {
rundir="/run"
chrpath=False
gpsd_user=gpsd
- gpsd_group=uucp
+ gpsd_group=dialout
nostrip=True
manbuild=False
shared=$(usex !static True False)
@@ -190,9 +191,3 @@ src_install() {
use python && distutils-r1_src_install
}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}