summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-cbc')
-rw-r--r--sci-libs/coinor-cbc/Manifest1
-rw-r--r--sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild74
-rw-r--r--sci-libs/coinor-cbc/metadata.xml11
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/coinor-cbc/Manifest b/sci-libs/coinor-cbc/Manifest
new file mode 100644
index 000000000000..481c63bf08fa
--- /dev/null
+++ b/sci-libs/coinor-cbc/Manifest
@@ -0,0 +1 @@
+DIST Cbc-2.8.9.tgz 8231882 SHA256 33b121e43d35fd18b2084cd52a3bfabd5e8e8819bac3c906e33e0b7c017da288 SHA512 ff537a46a8a266767817bc28d61f4541cfda6e8617c857fa0abef4c0b4ef8fbc728dd195645898d94130dfaedb258789bf55e189a0b9665590958355135f020e WHIRLPOOL bb1512065a447f0ec7582076553e06966810d155768cc1277942251c0ad16ba22ad808ed3be7546873ae40ed68f54ae2b342f7906a366991e3ccea56acb45706
diff --git a/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild b/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild
new file mode 100644
index 000000000000..dcb7ee8136b9
--- /dev/null
+++ b/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib flag-o-matic
+
+MYPN=Cbc
+
+DESCRIPTION="COIN-OR Branch-and-Cut Mixed Integer Programming Solver"
+HOMEPAGE="https://projects.coin-or.org/Cbc/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # hack for parallel build, to overcome not patching Makefile.am above
+ autotools-utils_src_compile -C src libCbc.la
+ autotools-utils_src_compile -C src libCbcSolver.la
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ # hack for parallel install, to overcome not patching Makefile.am above
+ autotools-utils_src_install -C src install-am
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-cbc/metadata.xml b/sci-libs/coinor-cbc/metadata.xml
new file mode 100644
index 000000000000..340871a6b828
--- /dev/null
+++ b/sci-libs/coinor-cbc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ COIN-OR Branch-and-Cut is a Mixed integer linear programming
+ solver. It uses many of the COIN-OR components and is designed to be
+ used with COIN-OR CLP or COIN-OR Dylp. It is available as a library and as a
+ standalone solver.
+</longdescription>
+</pkgmetadata>