summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/Manifest1
-rw-r--r--sci-libs/libdap/files/libdap-3.11.3-gcc-4.7.patch15
-rw-r--r--sci-libs/libdap/libdap-3.11.3.ebuild52
-rw-r--r--sci-libs/libdap/metadata.xml14
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-libs/libdap/Manifest b/sci-libs/libdap/Manifest
new file mode 100644
index 000000000000..9035b2744acf
--- /dev/null
+++ b/sci-libs/libdap/Manifest
@@ -0,0 +1 @@
+DIST libdap-3.11.3.tar.gz 1514429 SHA256 1fe14594960c1c24842ea9c3a4032cfce70b7082bbab17369b43c9a134ddac97 SHA512 acdb54e135a153107460cad2310176b9d4a3f9b7c142eca3456ba9331f551d1855f7e6d4b7fdce6586dd266e54e23b795f903499f349d26481ca1d9abb5f52a0 WHIRLPOOL f67a56c64937610047de2cf2ea362193506fbd474aa0f1aa38a88e3c49e3e6fb3a5d8969feddc34c7560afa0b5c9e1304b5ced46ce3d37e9333094a2da289db0
diff --git a/sci-libs/libdap/files/libdap-3.11.3-gcc-4.7.patch b/sci-libs/libdap/files/libdap-3.11.3-gcc-4.7.patch
new file mode 100644
index 000000000000..a0d411b03dc7
--- /dev/null
+++ b/sci-libs/libdap/files/libdap-3.11.3-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ ResponseBuilder.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/ResponseBuilder.cc b/ResponseBuilder.cc
+index 1135678..0356172 100644
+--- a/ResponseBuilder.cc
++++ b/ResponseBuilder.cc
+@@ -41,6 +41,7 @@ static char rcsid[] not_used = { "$Id
+ #include <string>
+ #include <sstream>
+ #include <cstring>
++#include <unistd.h>
+
+ #include <uuid/uuid.h> // used to build CID header value for data ddx
+ #include "DAS.h"
diff --git a/sci-libs/libdap/libdap-3.11.3.ebuild b/sci-libs/libdap/libdap-3.11.3.ebuild
new file mode 100644
index 000000000000..81b4331025c7
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.11.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
+HOMEPAGE="http://opendap.org/"
+SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 URI )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-util/cppunit
+ dev-libs/libxml2:2
+ net-misc/curl
+ sys-libs/zlib
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+DOCS=( README NEWS README.dodsrc )
+
+RESTRICT="test"
+# needs http connection
+# FAIL: MIMEUtilTest
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile docs
+}
+
+src_test() {
+ emake check
+ cd "${S}"/unit-tests
+ emake check
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+}
diff --git a/sci-libs/libdap/metadata.xml b/sci-libs/libdap/metadata.xml
new file mode 100644
index 000000000000..ffb17615be3a
--- /dev/null
+++ b/sci-libs/libdap/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<longdescription>
+ libdap is a C++ implementation of OPeNDAP which allows access to
+ data over the internet, from programs that weren't originally
+ designed for that purpose, as well as some that were. While OPeNDAP
+ is the original developer of the Data Access Protocol (DAP) which
+ it's software uses, many other groups have adopted DAP and provide
+ compatible clients, servers and software development kits. DAP is a
+ NASA community standard: http://www.esdswg.org/spg/rfc/ese-rfc-004
+</longdescription>
+</pkgmetadata>