summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libnova/libnova-0.15.0.ebuild')
-rw-r--r--sci-libs/libnova/libnova-0.15.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sci-libs/libnova/libnova-0.15.0.ebuild b/sci-libs/libnova/libnova-0.15.0.ebuild
deleted file mode 100644
index a0f7d8f6be46..000000000000
--- a/sci-libs/libnova/libnova-0.15.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
-HOMEPAGE="http://libnova.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_prepare() {
- default
- sed -i -e '/CFLAGS=-Wall/d' configure.in || die
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_compile() {
- default
- use doc && emake -C doc doc
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/html/. )
- default
-
- if use examples; then
- emake clean
- rm examples/Makefile* || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}