summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/p4est')
-rw-r--r--sci-libs/p4est/Manifest4
-rw-r--r--sci-libs/p4est/metadata.xml25
-rw-r--r--sci-libs/p4est/p4est-1.0.ebuild99
-rw-r--r--sci-libs/p4est/p4est-1.1.ebuild99
-rw-r--r--sci-libs/p4est/p4est-9999.ebuild117
5 files changed, 344 insertions, 0 deletions
diff --git a/sci-libs/p4est/Manifest b/sci-libs/p4est/Manifest
new file mode 100644
index 000000000000..13859d7595c7
--- /dev/null
+++ b/sci-libs/p4est/Manifest
@@ -0,0 +1,4 @@
+DIST libsc-1.0.tar.gz 257930 SHA256 a9f8a0f342a4a92c4031735e044e7ee73d9fd7e6df3e50a51c4c5016e27ed1ba SHA512 bf5af600e9cbd4038b1bd40c88776b21be5d474e34f9aacf287b890d262a22dc50ca27982c2eb9adba9735c8d9bb1fc31de2a27b24cdab534e3b2f610d76db7d WHIRLPOOL 56f89fcaf90bc8d4f872cee4fe150f692933b39376758c42b67d2e42659c19a9332a1d5e6d2d81c011dade0c6ab40c526c69ce2168fe41060f5d4be1a6595b1b
+DIST libsc-1.1.tar.gz 263643 SHA256 99c3fb3b7d6514ccaa667bdc848a7308c00f05bf6fdc0561ce286db9644ee03e SHA512 a3d8bea406a1987e68e88dd587aebe28c796f2a5bddfc381b34b5eb1448e0ac23889cc6f97fc1e4010289f83996180db42cbb001d0518360349b993dd37d4579 WHIRLPOOL b6c123cd245e4beb4cd6479e9d781d86784fab6975edc20562c14b5ecc59dbc824aca10fb02e4fa7612f0b2743fd7c7d3799f203546c5859896812a21e1362df
+DIST p4est-1.0.tar.gz 695027 SHA256 d669b0487eb0d2765c77adcab551c447f2cfa49d60a5a9016eaf48526ece74b6 SHA512 781240bbca2779f4076c310575ad99e8b526ecf6a3da8b7b5f096615bbfb570dd0556e607797715b69c95c6dd73baf837f1c632be763efae835941107f1fe3df WHIRLPOOL 690e350c3960b48cf5ac6bbc9aeff49557da25a69e152b7dca8fdb91b424f1669e9cf603903fb3f4de01078b964c63f7811b63000cacc5d56845ba96f6c516bf
+DIST p4est-1.1.tar.gz 1241423 SHA256 14a4ba6c5883ece611c90fae29bc60a454c20db43df646b232bd5aa552acd5cf SHA512 11eb576a16a4cc959eff8894d6cb11d8bae092951be9cf9d71b538825bdf675af7fd77d79505b9e896ec1810c1f8e9391447a79263c6d2e33fef780e97d07f29 WHIRLPOOL 38253d7dd01d5406c5e7e773afdabcac85d49bedd86d3a325c227b32e9d09ddb5397a77e8485489a2e46c582ea242d5eaad877c139504088246d2b8d31b86c63
diff --git a/sci-libs/p4est/metadata.xml b/sci-libs/p4est/metadata.xml
new file mode 100644
index 000000000000..a7e30547b056
--- /dev/null
+++ b/sci-libs/p4est/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+The p4est software library enables the dynamic management of a collection
+of adaptive octrees, conveniently called a forest of octrees. p4est is
+designed to work in parallel and scale to hundreds of thousands of
+processor cores.
+ </longdescription>
+ <use>
+ <flag name="vtk-binary">Enable binary vtk output. If disabled vtk files will be written in ASCII text format.</flag>
+ <flag name="romio">Build with support for the ROMIO MPI-IO component</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">cburstedde/libsc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/p4est/p4est-1.0.ebuild b/sci-libs/p4est/p4est-1.0.ebuild
new file mode 100644
index 000000000000..637628420bf6
--- /dev/null
+++ b/sci-libs/p4est/p4est-1.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# The build system currently fails with everything newer than 1.11.
+WANT_AUTOMAKE=1.11
+
+inherit autotools eutils
+
+DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
+HOMEPAGE="http://www.p4est.org/"
+SRC_URI="
+ https://github.com/cburstedde/p4est/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/cburstedde/libsc/archive/v${PV}.tar.gz -> libsc-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="debug doc examples mpi romio static-libs +vtk-binary"
+REQUIRED_USE="romio? ( mpi )"
+
+RDEPEND="
+ ~sci-libs/libsc-${PV}[mpi=,romio=,static-libs=]
+ dev-lang/lua:*
+ sys-apps/util-linux
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[romio=] )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/automake:1.11
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ default
+
+ # Inject libsc to get all parts of the build system...
+ rmdir "${S}/sc" || die "rmdir failed"
+ mv "${WORKDIR}/libsc-${PV}" "${S}/sc" || die "mv failed"
+
+ # Inject a version number into the build system
+ echo "${PV}" > ${S}/.tarball-version
+
+ AT_M4DIR="${WORKDIR}/${P}/config ${WORKDIR}/${P}/sc/config"
+ eautoreconf
+
+ sed -i \
+ "s/P4EST_SC_DIR\/etc/P4EST_SC_DIR\/share\/libsc/" \
+ "${S}"/configure || die "sed failed"
+
+ sed -i \
+ "s/libsc\.la/libsc\.so/" \
+ "${S}"/configure || die "sed failed"
+}
+
+src_configure() {
+ # avoid underlinkage
+ LDFLAGS="${LDFLAGS} -lsc"
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable mpi)
+ $(use_enable romio mpiio)
+ $(use_enable static-libs static)
+ $(use_enable vtk-binary)
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-sc="${EPREFIX}/usr"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/*
+
+ if use examples
+ then
+ docinto examples
+ dodoc -r example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ # Remove compiled example binaries in case of -examples:
+ rm -r "${ED}"/usr/bin || die "rm failed"
+ fi
+
+ # Fix wrong installation paths:
+ dodir /usr/share/p4est
+ mv "${ED}"/usr/share/data "${ED}"/usr/share/p4est/data || die "mv failed"
+ mv "${ED}"/etc/* "${ED}"/usr/share/p4est || die "mv failed"
+ rmdir "${ED}"/etc/ || die "rmdir failed"
+}
diff --git a/sci-libs/p4est/p4est-1.1.ebuild b/sci-libs/p4est/p4est-1.1.ebuild
new file mode 100644
index 000000000000..637628420bf6
--- /dev/null
+++ b/sci-libs/p4est/p4est-1.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# The build system currently fails with everything newer than 1.11.
+WANT_AUTOMAKE=1.11
+
+inherit autotools eutils
+
+DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
+HOMEPAGE="http://www.p4est.org/"
+SRC_URI="
+ https://github.com/cburstedde/p4est/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/cburstedde/libsc/archive/v${PV}.tar.gz -> libsc-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="debug doc examples mpi romio static-libs +vtk-binary"
+REQUIRED_USE="romio? ( mpi )"
+
+RDEPEND="
+ ~sci-libs/libsc-${PV}[mpi=,romio=,static-libs=]
+ dev-lang/lua:*
+ sys-apps/util-linux
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[romio=] )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/automake:1.11
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ default
+
+ # Inject libsc to get all parts of the build system...
+ rmdir "${S}/sc" || die "rmdir failed"
+ mv "${WORKDIR}/libsc-${PV}" "${S}/sc" || die "mv failed"
+
+ # Inject a version number into the build system
+ echo "${PV}" > ${S}/.tarball-version
+
+ AT_M4DIR="${WORKDIR}/${P}/config ${WORKDIR}/${P}/sc/config"
+ eautoreconf
+
+ sed -i \
+ "s/P4EST_SC_DIR\/etc/P4EST_SC_DIR\/share\/libsc/" \
+ "${S}"/configure || die "sed failed"
+
+ sed -i \
+ "s/libsc\.la/libsc\.so/" \
+ "${S}"/configure || die "sed failed"
+}
+
+src_configure() {
+ # avoid underlinkage
+ LDFLAGS="${LDFLAGS} -lsc"
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable mpi)
+ $(use_enable romio mpiio)
+ $(use_enable static-libs static)
+ $(use_enable vtk-binary)
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-sc="${EPREFIX}/usr"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/*
+
+ if use examples
+ then
+ docinto examples
+ dodoc -r example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ # Remove compiled example binaries in case of -examples:
+ rm -r "${ED}"/usr/bin || die "rm failed"
+ fi
+
+ # Fix wrong installation paths:
+ dodir /usr/share/p4est
+ mv "${ED}"/usr/share/data "${ED}"/usr/share/p4est/data || die "mv failed"
+ mv "${ED}"/etc/* "${ED}"/usr/share/p4est || die "mv failed"
+ rmdir "${ED}"/etc/ || die "rmdir failed"
+}
diff --git a/sci-libs/p4est/p4est-9999.ebuild b/sci-libs/p4est/p4est-9999.ebuild
new file mode 100644
index 000000000000..38e6d1956842
--- /dev/null
+++ b/sci-libs/p4est/p4est-9999.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils
+
+DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
+HOMEPAGE="http://www.p4est.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/cburstedde/p4est.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/cburstedde/p4est/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/cburstedde/libsc/archive/v${PV}.tar.gz -> libsc-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+# TODO petsc
+IUSE="debug doc examples mpi openmp romio static-libs threads +vtk-binary"
+REQUIRED_USE="romio? ( mpi )"
+
+RDEPEND="
+ ~sci-libs/libsc-${PV}[mpi=,openmp=,romio=,static-libs=,threads=]
+ dev-lang/lua:*
+ sys-apps/util-linux
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[romio=] )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/automake:1.11
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use openmp; then
+ tc-has-openmp || \
+ die "Please select an openmp capable compiler like gcc[openmp]"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Inject libsc to get all parts of the build system...
+ if ! [[ ${PV} = *9999* ]]; then
+ rmdir "${S}/sc" || die "rmdir failed"
+ mv "${WORKDIR}/libsc-${PV}" "${S}/sc" || die "mv failed"
+ fi
+
+ # Inject a version number into the build system
+ echo "${PV}" > ${S}/.tarball-version
+
+ AT_M4DIR="${WORKDIR}/${P}/config ${WORKDIR}/${P}/sc/config"
+ eautoreconf
+
+ sed -i \
+ "s/P4EST_SC_DIR\/etc/P4EST_SC_DIR\/share\/libsc/" \
+ "${S}"/configure || die "sed failed"
+
+ sed -i \
+ "s/libsc\.la/libsc\.so/" \
+ "${S}"/configure || die "sed failed"
+
+}
+
+src_configure() {
+ # avoid underlinkage
+ LDFLAGS="${LDFLAGS} -lsc"
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable mpi)
+ $(use_enable openmp)
+ $(use_enable romio mpiio)
+ $(use_enable static-libs static)
+ $(use_enable threads pthread)
+ $(use_enable vtk-binary)
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ --with-sc="${EPREFIX}/usr"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/*
+
+ if use examples
+ then
+ docinto examples
+ dodoc -r example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ # Remove compiled example binaries in case of -examples:
+ rm -r "${ED}"/usr/bin || die "rm failed"
+ fi
+
+ # Fix wrong installation paths:
+ dodir /usr/share/p4est
+ mv "${ED}"/usr/share/data "${ED}"/usr/share/p4est/data || die "mv failed"
+ mv "${ED}"/etc/* "${ED}"/usr/share/p4est || die "mv failed"
+ rmdir "${ED}"/etc/ || die "rmdir failed"
+}