summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/nestedsums')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
index 86a84599f41c..3f4b9497fb6b 100644
--- a/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
@@ -13,8 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=">=sci-mathematics/ginac-1.7"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
src_compile() {
default
@@ -29,7 +29,12 @@ src_test() {
}
src_install() {
- use doc && local HTML_DOCS=( reference/html/. )
- default
- find "${D}" -name '*.la' -type f -delete || die
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ docinto html
+ dodoc -r reference/html/.
+ fi
}