summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elivepatch-server')
-rw-r--r--sys-apps/elivepatch-server/Manifest1
-rw-r--r--sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild29
-rw-r--r--sys-apps/elivepatch-server/metadata.xml10
3 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-server/Manifest b/sys-apps/elivepatch-server/Manifest
new file mode 100644
index 000000000000..adad4cdaf7cb
--- /dev/null
+++ b/sys-apps/elivepatch-server/Manifest
@@ -0,0 +1 @@
+DIST elivepatch-server-0.1.tar.gz 11564 SHA256 8ce02c1284b5822fdb4c762fe45b6d3ea8d9f360bce5c59f42c96b3aa41e4908 SHA512 d469fbc32df7a586fa899c6e587832bd53c1984c97b973e3aad4f6bf62962846142938a6e6e5729fce39d3f7d486c5ed9fd9f484425d863a40a1199f170830fb WHIRLPOOL 98e7a30c8cfda908fa010185e5a508926e57c813a610156d163bdca116d6ef6e59ba31fe8a427a84a558d84a0d9f7ad7387db7b9536e5651a91de22d46648246
diff --git a/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild b/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild
new file mode 100644
index 000000000000..84d6c4fbb2e3
--- /dev/null
+++ b/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch building server with RESTFul Api for elivepatch-client"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+SRC_URI="https://github.com/aliceinwire/elivepatch-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-restful[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newinitd init/elivepatch.init ${PN}
+ newconfd init/elivepatch.confd ${PN}
+ distutils-r1_python_install_all
+}
diff --git a/sys-apps/elivepatch-server/metadata.xml b/sys-apps/elivepatch-server/metadata.xml
new file mode 100644
index 000000000000..d7e109285f1a
--- /dev/null
+++ b/sys-apps/elivepatch-server/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alicef@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aliceinwire/elivepatch-server</remote-id>
+ </upstream>
+</pkgmetadata>