summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/restartd')
-rw-r--r--sys-apps/restartd/restartd-0.2.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/restartd/restartd-0.2.2-r1.ebuild b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..dadb97c5f33b
--- /dev/null
+++ b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_alpha/.a-}
+DESCRIPTION="A daemon for checking your running and not running processes"
+HOMEPAGE="https://packages.debian.org/unstable/utils/restartd"
+SRC_URI="mirror://debian/pool/main/r/restartd/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ sed -i Makefile -e 's|-o restartd|$(LDFLAGS) &|g' || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) C_ARGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /etc /usr/sbin /usr/share/man/man8 /usr/share/man/fr/man8/
+ default
+}