summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/epoch/Manifest1
-rw-r--r--sys-apps/epoch/epoch-1.2.2.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/sys-apps/epoch/Manifest b/sys-apps/epoch/Manifest
index 15c9f2cab1e3..ce77f48c8151 100644
--- a/sys-apps/epoch/Manifest
+++ b/sys-apps/epoch/Manifest
@@ -1,3 +1,2 @@
DIST epoch-1.2.1.tar.gz 66718 BLAKE2B 1fc75001ead0f65df6a303ae4933995eb5607e4f8f2de21c2b74b95f7a8a5ca0be21bf6c509826d36c79795905a1f65c18a755b7944d0eceb0364abc1d58613a SHA512 2d0c767165ec41452d1dabf338c8ea31772f1a8cd1e1dbd60c8469f2f235bb1f0cb60b467189f1fd1079dfc223b0687c1cfe5e729e1142ebc63323b1f9c0cf93
-DIST epoch_1.2.2.tar.gz 229377 BLAKE2B 0f2c00df56a7d35dd224b8a1b22c78dae943c09eabb78c72cddc1085d5596cf6ef23b4d0c240191bb6b69e511a97f0bdb9f0cf99a4146097211867ae1beaf213 SHA512 9e3e38ef95c20237a3db4f47c9464f27e893a665f0692200d89e96b12f6b2e3af9b84d951356b7b354f19ea4fbe372e2e0ba406fdfeb8819914d46cfed3024a3
DIST epoch_1.3.0.tar.gz 70681 BLAKE2B 7ad2ab4c7f6c5544138aeb29a9b3a3f8889ade23b448abf1ec257fc7bbf811f4f6b01f0c9c81005aec56fe243d1f1e53a2daacdcdc4ff935bfcbd707fb8b2ab6 SHA512 1e4a8bee26d8819303cbeb67265ee74e294502acfb3f5e594222bb7bdcb2d077fe19e73c40e9111a6ef9af788d767434f5a9a357430b59d6a0cac0e36a3b8f9e
diff --git a/sys-apps/epoch/epoch-1.2.2.ebuild b/sys-apps/epoch/epoch-1.2.2.ebuild
deleted file mode 100644
index af18fc85b21a..000000000000
--- a/sys-apps/epoch/epoch-1.2.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit epatch linux-info
-
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
-HOMEPAGE="http://universe2.us/epoch.html"
-SRC_URI="http://universe2.us/${PN}_${PV}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-S="${WORKDIR}/${PN}_${PV}"
-
-pkg_pretend() {
- local CONFIG_CHECK="~PROC_FS"
-
- [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
-}
-
-src_compile() {
- NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
-}
-
-newepochins() {
- local type="$1"
-
- cd ${type} || die "Cannot change directory."
- for file in * ; do
- if [[ "${file}" != "epoch" ]] ; then
- new${type} ${file} epoch-${file}
- fi
- done
- cd .. || die "Cannot change directory."
-}
-
-src_install() {
- cd built || die "Cannot change directory."
-
- dosbin sbin/epoch
-
- # For now, rename to epoch-* until we can blend in with a standard approach.
- newepochins bin
- newepochins sbin
-
- insinto /etc/epoch/
- newins "${FILESDIR}"/${PN}-1.0-epoch.conf epoch.conf
-}
-
-pkg_postinst() {
- elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
- elog ""
- elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
- elog "which starts a minimal needed to use Gentoo."
- elog ""
- elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
- elog ""
- elog "Additional information about epoch is available at"
- elog "${HOMEPAGE} and configuration documentation at"
- elog "http://universe2.us/epochconfig.html which is useful reading material."
- elog ""
- elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
-}