summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_require/pam_require-0.7.ebuild')
-rw-r--r--sys-auth/pam_require/pam_require-0.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-auth/pam_require/pam_require-0.7.ebuild b/sys-auth/pam_require/pam_require-0.7.ebuild
new file mode 100644
index 000000000000..880c202f9618
--- /dev/null
+++ b/sys-auth/pam_require/pam_require-0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils pam
+
+DESCRIPTION="Allows you to require a special group or user to access a service"
+HOMEPAGE="http://www.splitbrain.org/projects/pam_require"
+SRC_URI="http://www.splitbrain.org/_media/projects/pamrequire/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/pam"
+
+S=${WORKDIR}/${P/_/-}
+
+src_compile() {
+ ./configure --prefix=/ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dopammod "${S}/pam_require.so"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}