summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/blktrace/blktrace-1.1.0.ebuild')
-rw-r--r--sys-block/blktrace/blktrace-1.1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-block/blktrace/blktrace-1.1.0.ebuild b/sys-block/blktrace/blktrace-1.1.0.ebuild
new file mode 100644
index 000000000000..23c11b3bd066
--- /dev/null
+++ b/sys-block/blktrace/blktrace-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-ldflags-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}