summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/files/refind-0.12.0-gcc10.patch11
-rw-r--r--sys-boot/refind/refind-0.12.0-r1.ebuild12
2 files changed, 19 insertions, 4 deletions
diff --git a/sys-boot/refind/files/refind-0.12.0-gcc10.patch b/sys-boot/refind/files/refind-0.12.0-gcc10.patch
new file mode 100644
index 000000000000..1f2e2bc0a5de
--- /dev/null
+++ b/sys-boot/refind/files/refind-0.12.0-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/Make.common
++++ b/Make.common
+@@ -60,7 +60,7 @@
+ #
+
+ # ...for both GNU-EFI and TianoCore....
+-OPTIMFLAGS = -Os -fno-strict-aliasing
++OPTIMFLAGS = -Os -fno-strict-aliasing -fno-tree-loop-distribute-patterns
+ CFLAGS = $(OPTIMFLAGS) -fno-stack-protector -fshort-wchar -Wall
+
+ # ...for GNU-EFI....
diff --git a/sys-boot/refind/refind-0.12.0-r1.ebuild b/sys-boot/refind/refind-0.12.0-r1.ebuild
index b595a111e7e0..f63a0cbd3243 100644
--- a/sys-boot/refind/refind-0.12.0-r1.ebuild
+++ b/sys-boot/refind/refind-0.12.0-r1.ebuild
@@ -15,10 +15,14 @@ KEYWORDS="~amd64 ~x86"
FS_USE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
IUSE="${FS_USE} custom-cflags doc"
-DEPEND=">=sys-boot/gnu-efi-3.0.2"
+DEPEND="sys-boot/gnu-efi"
-DOCS=(README.txt)
-PATCHES=("${FILESDIR}/makefile.patch")
+PATCHES=(
+ "${FILESDIR}/makefile.patch"
+ "${FILESDIR}/${P}-gcc10.patch" # Bug 723244
+)
+
+DOCS=( README.txt )
pkg_pretend() {
if use custom-cflags; then
@@ -78,7 +82,7 @@ src_compile() {
FILESYSTEMS_GNUEFI="${fs_names[@]}"
)
if use custom-cflags; then
- make_flags=(CFLAGS="${CFLAGS}" "${make_flags[@]}")
+ make_flags=(CFLAGS="${CFLAGS} -fno-tree-loop-distribute-patterns" "${make_flags[@]}")
fi
emake "${make_flags[@]}" all_gnuefi