summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.11.6-r3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.11.6-r3.ebuild39
1 files changed, 16 insertions, 23 deletions
diff --git a/sys-devel/automake/automake-1.11.6-r3.ebuild b/sys-devel/automake/automake-1.11.6-r3.ebuild
index fb2d2c65c290..58ccde9a40ba 100644
--- a/sys-devel/automake/automake-1.11.6-r3.ebuild
+++ b/sys-devel/automake/automake-1.11.6-r3.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
+EAPI=7
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="https://www.gnu.org/software/automake/"
@@ -14,16 +11,16 @@ LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
+RESTRICT="test"
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-10
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
+ sys-apps/help2man"
+BDEPEND="app-arch/gzip"
PATCHES=(
"${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
@@ -31,14 +28,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket-r1.patch
)
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
export WANT_AUTOCONF=2.5
- chmod a+rx tests/*.test
export HELP2MAN=true
sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
export TZ="UTC" #589138
@@ -56,7 +48,7 @@ src_compile() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir || die
# Rewrite all the references to other pages.
@@ -82,24 +74,25 @@ slot_info_pages() {
popd >/dev/null || die
}
-src_test() {
- unset HELP2MAN # 583108
-
- default
-}
-
src_install() {
default
slot_info_pages
rm \
- "${ED%/}"/usr/bin/{aclocal,automake} \
- "${ED%/}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
}