summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.1_rc5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 10bda4781298..ad690124ff27 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-5.1-rc1.patch 38814968 BLAKE2B 857ecb5a7c0e6514bedd377dd70602083953ad
DIST patch-5.1-rc2.patch 39225075 BLAKE2B 3b4efa4ac54a76f18ec1cea311c21f9599a5d353d89fced007673633ef137d4dbdaa8b1617614784d53fbe8b44fed26318d7ef51baf2f80467d0801a0e57dd7f SHA512 6872b3513fb6f8e2d6de9d83d1dd7e182e4a60a3e9638e53072b3513c21bdd1ea7f081ce5c28e5d53b5a60859e14de1959de2f24d6c91ef3a2db0318240f7eb8
DIST patch-5.1-rc3.patch 39886006 BLAKE2B f4777ad45eeef9281df9bb4255e2d70750e7cd63ba09ce78fd7a218f754ca6748efda3cb873facbf8316fc32920c755b8ca1f4eb066aeda8e177d4261e67107f SHA512 96d20dde7efdb73077939414752d37dd20623b7efca396a4a676b2fb2f7388a5eb552933e3007a7960e0c031145bdd7f630cc9b6380d57a6a5917553ae8e2fb0
DIST patch-5.1-rc4.patch 40198305 BLAKE2B 981cf99dcc6102bc45e240577b5ab5d566ede507cd753139d52255d4145a0c72c3eb07b1b4f275f65ebe13ac6f67ba74c93d99ab44aa8e33ee4779b977f87685 SHA512 a3b29cd28403893b76961e184391421ee14580645224d92e9fee38a067d4dc184594ee5204141c94ce0e891cf7ba0f66e123f09ad723263ac64d607a737b5df8
+DIST patch-5.1-rc5.patch 40391650 BLAKE2B 3f6d76f528e9eed9611315362e1c78821968c28cd852fc8d02dd052a5175889583260557207a9b85bd4af4df5d4f65d2d83b222b7791fc6075684289f5184a2c SHA512 97f211fff49def57cc89aaac7f56d3421a2577d8fb8154ca3a7ccc4905a8c02a23e4e5a539ab8e6085fd98a6b8876c0db98535acef8b1a3be687f11005741cd5
diff --git a/sys-kernel/git-sources/git-sources-5.1_rc5.ebuild b/sys-kernel/git-sources/git-sources-5.1_rc5.ebuild
new file mode 100644
index 000000000000..775e4fb8b978
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.1_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.0"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}