summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-6.0.35.ebuild')
-rw-r--r--sys-libs/db/db-6.0.35.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-libs/db/db-6.0.35.ebuild b/sys-libs/db/db-6.0.35.ebuild
index 357f5ac8131d..6fcfe907e32b 100644
--- a/sys-libs/db/db-6.0.35.ebuild
+++ b/sys-libs/db/db-6.0.35.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(