summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/Manifest1
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r2.ebuild17
2 files changed, 15 insertions, 3 deletions
diff --git a/sys-libs/gpm/Manifest b/sys-libs/gpm/Manifest
index afdac3e0fa24..b637cdccc9d7 100644
--- a/sys-libs/gpm/Manifest
+++ b/sys-libs/gpm/Manifest
@@ -1 +1,2 @@
+DIST gpm-1.20.7-docs.patch.xz 41668 SHA256 a1b73e8916d1ae5e336a6c366c2be51b668176d743bb137a53c623f5a634faf6 SHA512 6cdcad70d0a77a56cb507330ff8409155de11255b5e61fb92ee439c1e117932c346df475f4187abb0e348ee4c28fa235a9693883b1c36913e91404662df272f4 WHIRLPOOL f6832979bc5b3ca1c61f150ab8795f744dc3d44fa404038dd5de97c4fd939e2e1fb4b40bcb27daf5cb81846a0841954dbfa5b8d6e37e341b834d9dce6382dcf1
DIST gpm-1.20.7.tar.lzma 789691 SHA256 a955053b36556ffa7c628ce18fd6de7d625966573fa412fb08869533d8f7385c SHA512 a502741e2f457b47e41c6d155b1f7ef7c95384fd394503f82ddacf80cde9cdc286c906c77be12b6af8565ef1c3ab24d226379c1dcebcfcd15d64bcf3e94b63b9 WHIRLPOOL d3d142c3aa385e2ef4b16c96e0f94c04b3666376d893c516d439737c2f3016a12fff7884a8f18b5e6b58e4ba21d82379204b18621a2f338d8ab6d478e4e1ec1a
diff --git a/sys-libs/gpm/gpm-1.20.7-r2.ebuild b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
index ee9f5a7005ef..58415add2425 100644
--- a/sys-libs/gpm/gpm-1.20.7-r2.ebuild
+++ b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
@@ -10,7 +10,8 @@ inherit eutils systemd toolchain-funcs autotools multilib-minimal
DESCRIPTION="Console-based mouse driver"
HOMEPAGE="http://www.nico.schottelius.org/software/gpm/"
-SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma
+ mirror://gentoo/${P}-docs.patch.xz"
LICENSE="GPL-2"
SLOT="0"
@@ -30,14 +31,26 @@ DEPEND=">=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}]
src_prepare() {
epatch "${FILESDIR}"/${P}-sysmacros.patch
+
+ # Hack up the docs until we get this sorted upstream.
+ # https://github.com/telmich/gpm/issues/8
+ epatch "${WORKDIR}"/${P}-docs.patch
+ touch -r . doc/* || die
+
# fix ABI values
sed -i \
-e '/^abi_lev=/s:=.*:=1:' \
-e '/^abi_age=/s:=.*:=20:' \
configure.ac.footer || die
+ # Rebuild autotools since release doesn't include them.
+ # Should be fixed with the next release though.
+ # https://github.com/telmich/gpm/pull/15
sed -i -e '/ACLOCAL/,$d' autogen.sh || die
./autogen.sh
eautoreconf
+
+ # Out-of-tree builds are broken.
+ # https://github.com/telmich/gpm/issues/16
multilib_copy_sources
}
@@ -49,8 +62,6 @@ multilib_src_configure() {
}
multilib_src_compile() {
- # make sure nothing compiled is left
- emake clean
emake EMACS=: $(multilib_is_native_abi || echo "PROG= ")
}