summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild10
-rw-r--r--sys-libs/glibc/glibc-2.27-r2.ebuild10
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild10
3 files changed, 15 insertions, 15 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 1b071fb4d3d5..b2b9a397b55c 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -895,8 +895,8 @@ glibc_do_configure() {
--with-bugurl=https://bugs.gentoo.org/
--with-pkgversion="$(glibc_banner)"
$(use_multiarch || echo --disable-multi-arch)
- $(in_iuse systemtap && use_enable systemtap)
- $(in_iuse nscd && use_enable nscd)
+ $(use_enable systemtap)
+ $(use_enable nscd)
${EXTRA_ECONF}
)
@@ -904,8 +904,8 @@ glibc_do_configure() {
myconf+=( $(use_enable vanilla timezone-tools) )
# These libs don't have configure flags.
- ac_cv_lib_audit_audit_log_user_avc_message=$(in_iuse audit && usex audit || echo no)
- ac_cv_lib_cap_cap_init=$(in_iuse caps && usex caps || echo no)
+ ac_cv_lib_audit_audit_log_user_avc_message=$(usex audit || echo no)
+ ac_cv_lib_cap_cap_init=$(usex caps || echo no)
# There is no configure option for this and we need to export it
# since the glibc build will re-run configure on itself
@@ -1174,7 +1174,7 @@ glibc_do_src_install() {
# With devpts under Linux mounted properly, we do not need the pt_chown
# binary to be setuid. This is because the default owners/perms will be
# exactly what we want.
- if in_iuse suid && ! use suid ; then
+ if ! use suid ; then
find "${ED}" -name pt_chown -exec chmod -s {} +
fi
diff --git a/sys-libs/glibc/glibc-2.27-r2.ebuild b/sys-libs/glibc/glibc-2.27-r2.ebuild
index b45dd3a49214..3d2fa2400250 100644
--- a/sys-libs/glibc/glibc-2.27-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r2.ebuild
@@ -894,8 +894,8 @@ glibc_do_configure() {
--with-bugurl=https://bugs.gentoo.org/
--with-pkgversion="$(glibc_banner)"
$(use_multiarch || echo --disable-multi-arch)
- $(in_iuse systemtap && use_enable systemtap)
- $(in_iuse nscd && use_enable nscd)
+ $(use_enable systemtap)
+ $(use_enable nscd)
${EXTRA_ECONF}
)
@@ -903,8 +903,8 @@ glibc_do_configure() {
myconf+=( $(use_enable vanilla timezone-tools) )
# These libs don't have configure flags.
- ac_cv_lib_audit_audit_log_user_avc_message=$(in_iuse audit && usex audit || echo no)
- ac_cv_lib_cap_cap_init=$(in_iuse caps && usex caps || echo no)
+ ac_cv_lib_audit_audit_log_user_avc_message=$(usex audit || echo no)
+ ac_cv_lib_cap_cap_init=$(usex caps || echo no)
# There is no configure option for this and we need to export it
# since the glibc build will re-run configure on itself
@@ -1209,7 +1209,7 @@ glibc_do_src_install() {
# With devpts under Linux mounted properly, we do not need the pt_chown
# binary to be setuid. This is because the default owners/perms will be
# exactly what we want.
- if in_iuse suid && ! use suid ; then
+ if ! use suid ; then
find "${ED}" -name pt_chown -exec chmod -s {} +
fi
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 7c5d09ab85ac..ee82933c6632 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -886,8 +886,8 @@ glibc_do_configure() {
--with-bugurl=https://bugs.gentoo.org/
--with-pkgversion="$(glibc_banner)"
$(use_multiarch || echo --disable-multi-arch)
- $(in_iuse systemtap && use_enable systemtap)
- $(in_iuse nscd && use_enable nscd)
+ $(use_enable systemtap)
+ $(use_enable nscd)
${EXTRA_ECONF}
)
@@ -895,8 +895,8 @@ glibc_do_configure() {
myconf+=( $(use_enable vanilla timezone-tools) )
# These libs don't have configure flags.
- ac_cv_lib_audit_audit_log_user_avc_message=$(in_iuse audit && usex audit || echo no)
- ac_cv_lib_cap_cap_init=$(in_iuse caps && usex caps || echo no)
+ ac_cv_lib_audit_audit_log_user_avc_message=$(usex audit || echo no)
+ ac_cv_lib_cap_cap_init=$(usex caps || echo no)
# There is no configure option for this and we need to export it
# since the glibc build will re-run configure on itself
@@ -1201,7 +1201,7 @@ glibc_do_src_install() {
# With devpts under Linux mounted properly, we do not need the pt_chown
# binary to be setuid. This is because the default owners/perms will be
# exactly what we want.
- if in_iuse suid && ! use suid ; then
+ if ! use suid ; then
find "${ED}" -name pt_chown -exec chmod -s {} +
fi