summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/liquid_feedback_core')
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild12
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild12
2 files changed, 10 insertions, 14 deletions
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild
index a914251c479c..6980d685f120 100644
--- a/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-2.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P=${PN}-v${PV}
@@ -16,14 +16,12 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND="dev-db/postgresql"
+RDEPEND="dev-db/postgresql:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2.3-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${PN}-2.2.3-gentoo.patch )
src_compile() {
emake \
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
index 982f8b95469d..0e52e88b06a7 100644
--- a/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-3.0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P=${PN}-v${PV}
@@ -16,14 +16,12 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND="dev-db/postgresql"
+RDEPEND="dev-db/postgresql:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.4-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${PN}-3.0.4-gentoo.patch )
src_compile() {
emake \