summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild67
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild62
2 files changed, 0 insertions, 129 deletions
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild
deleted file mode 100644
index 554832d3049d..000000000000
--- a/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils autotools
-
-MY_PV=${PV/_beta/b}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="HTTP/HTML indexing and searching system"
-HOMEPAGE="http://www.htdig.org"
-SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="ssl"
-
-DEPEND=">=sys-libs/zlib-1.1.3
- app-arch/unzip
- ssl? ( dev-libs/openssl )"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc4.patch
- epatch "${FILESDIR}"/${P}-as-needed.patch
- epatch "${FILESDIR}"/${P}-quoting.patch
- sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in db/configure.in || die
- eautoreconf
-}
-
-src_compile() {
- use prefix || EPREFIX=
-
- econf \
- --with-config-dir="${EPREFIX}"/etc/${PN} \
- --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf \
- --with-database-dir="${EPREFIX}"/var/lib/${PN}/db \
- --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin \
- --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
- --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
- $(use_with ssl)
-
-# --with-image-url-prefix="file://${EPREFIX}/var/www/localhost/htdocs/${PN}" \
-
- emake || die "emake failed"
-}
-
-src_install () {
- use prefix || ED="${D}"
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc ChangeLog README
- dohtml -r htdoc
-
- sed -i "s:${D}::g" \
- "${ED}"/etc/${PN}/${PN}.conf \
- "${ED}"/usr/bin/rundig \
- || die "sed failed (removing \${D} from installed files)"
-
- # symlink htsearch so it can be easily found. see bug #62087
- dosym ../../var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
-}
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild
deleted file mode 100644
index 3a45503a87a8..000000000000
--- a/www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils autotools
-
-MY_PV=${PV/_beta/b}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="HTTP/HTML indexing and searching system"
-HOMEPAGE="http://www.htdig.org"
-SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="libressl ssl"
-
-DEPEND=">=sys-libs/zlib-1.1.3
- app-arch/unzip
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc4.patch
- epatch "${FILESDIR}"/${P}-as-needed.patch
- epatch "${FILESDIR}"/${P}-quoting.patch
- epatch "${FILESDIR}"/${P}-gcc6.patch
- sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in db/configure.in || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-config-dir="${EPREFIX}"/etc/${PN} \
- --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf \
- --with-database-dir="${EPREFIX}"/var/lib/${PN}/db \
- --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin \
- --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
- --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
- $(use_with ssl)
-
-# --with-image-url-prefix="file://${EPREFIX}/var/www/localhost/htdocs/${PN}" \
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc ChangeLog README
- dohtml -r htdoc
-
- sed -i "s:${D}::g" \
- "${ED}"/etc/${PN}/${PN}.conf \
- "${ED}"/usr/bin/rundig \
- || die "sed failed (removing \${D} from installed files)"
-
- # symlink htsearch so it can be easily found. see bug #62087
- dosym ../../var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
-}