summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/Manifest1
-rw-r--r--www-servers/tomcat/files/tomcat-7.0.75-build.xml.patch149
-rw-r--r--www-servers/tomcat/tomcat-7.0.75.ebuild149
3 files changed, 299 insertions, 0 deletions
diff --git a/www-servers/tomcat/Manifest b/www-servers/tomcat/Manifest
index 135d50b9f480..04643d98a86a 100644
--- a/www-servers/tomcat/Manifest
+++ b/www-servers/tomcat/Manifest
@@ -1,4 +1,5 @@
DIST apache-tomcat-7.0.73-src.tar.gz 4674971 SHA256 e3e236fb551ae9deb85024d8472fd08a76b14380e3ddaa2a1aff1fc670de5d87 SHA512 4754628c271d0aed3572ac0961c47653c10fcdfd0d13d8d1bc1b5774e961e6327cbb6b11b0e7e2f8eff525e2e60f741da49aeb855bb9d94e84cc87f346cf9ce6 WHIRLPOOL b9e75f53e41f1e9b9767fe8bc603ee5b7db2d3b1b7d2d900d430f4c0b73881a7ad36e0a0bfce773432b73ea8743865e933363ceec037d11d8f1008d8619ac1f1
+DIST apache-tomcat-7.0.75-src.tar.gz 4657629 SHA256 ffa9489ecd9aa0750598e5db0dc3275ce7e29de13f16d7bf863e0477bf338463 SHA512 2b7a0fc64ca58849713435993768b1f77666ad23f22cfb6091503bc1393f2c4fd3a61dac518efe4ccb22738d82fa81b1a1597ba148f4f829a0c642d131270117 WHIRLPOOL eada3af432dd943ca494ab3fbedfeaf655dbe621b639791e224cd0f58d1c26f8e6e99496757c21073249ef0af2bfa101dd8374f9d708777b331c31da663c435a
DIST apache-tomcat-8.0.39-src.tar.gz 5019148 SHA256 566bf43a50f42af9c5b46be60f68e571a56c41f8e93647cf9f68e5f93870be96 SHA512 0f58f2ef0dc047189672107b1f2586731e9455c3e665210d5634f5f5a16b0afd7ef5c35beaf02e22b874d4898ab62d33638785d9f18714893674bc691b0f9330 WHIRLPOOL 62baaba90f588c43ea503eb336d1b385b3a00b86686c1e232a836975f10d12241416b688279ffcd60dd42afb9d9660b6385e749c0c4d0877217f7494539f2752
DIST apache-tomcat-8.5.9-src.tar.gz 5059352 SHA256 65b4ed45950263cb4e4ca82a9b469943053eb85656a7568d6e0eb446ab34afe5 SHA512 85534e88467b298dfbf6d3ec274592da4e73c34ee3f8e84582f95aa7f69959b47076a7fd9e31c705b12e914fefad53ffc954a09c7d7f3da0203752033e70bf17 WHIRLPOOL 0dbcbc1bc0c9fdb8ca50dc7d630dc86d92c606a0e554e6fd8f68c1d34682e2581d4b730198161f75e64340c857f251244237ae0dcbc406caa90585236b5d69df
DIST apache-tomcat-9.0.0.M15-src.tar.gz 5075694 SHA256 c8101177073c2a4aa63cf04ef58226a2768b1cfacb14861d74966881a2791251 SHA512 76d68ebe49f8d5f3c1dcfc629b901453eda58410d071db1e5c1e339fb6aeda54d1402f00a4056e368ea8495841d462d46d4d62dbedb52dc538dc587fdc4f3757 WHIRLPOOL c098ee812b84ca617b710a154a3505ef0c0fcc9616c69db0e6396e300e2b90a3ed684507e407aaab6efdccbb5ea109b8e3d203f09062d25df7479296a5dfe049
diff --git a/www-servers/tomcat/files/tomcat-7.0.75-build.xml.patch b/www-servers/tomcat/files/tomcat-7.0.75-build.xml.patch
new file mode 100644
index 000000000000..481591fb6ff5
--- /dev/null
+++ b/www-servers/tomcat/files/tomcat-7.0.75-build.xml.patch
@@ -0,0 +1,149 @@
+diff -Naur apache-tomcat-7.0.63-src.orig/build.xml apache-tomcat-7.0.63-src/build.xml
+--- apache-tomcat-7.0.63-src.orig/build.xml 2015-06-30 09:15:44.000000000 +0100
++++ apache-tomcat-7.0.63-src/build.xml 2015-08-22 21:13:12.453038827 +0100
+@@ -660,12 +660,14 @@
+ </fileset>
+ </copy>
+ <!-- Copy JSP Schemas and DTDs to be packed into servlet-api.jar -->
++<!--
+ <copy todir="${tomcat.classes}/javax/servlet/resources" encoding="ISO-8859-1">
+ <fileset dir="${tomcat.classes}/javax/servlet/jsp/resources">
+ <include name="*" />
+ <exclude name="jspxml*" />
+ </fileset>
+ </copy>
++-->
+
+ </target>
+
+@@ -721,26 +723,32 @@
+ manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+
+ <!-- Servlet 3.0 Implementation JAR File -->
++<!--
+ <jarIt jarfile="${servlet-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.servlet-api"
+ manifest="${tomcat.manifests}/servlet-api.jar.manifest"
+ notice="${tomcat.manifests}/servlet-api.jar.notice"
+ license="${tomcat.manifests}/servlet-api.jar.license" />
++-->
+
+ <!-- JSP 2.2 Implementation JAR File -->
++<!--
+ <jarIt jarfile="${jsp-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.jsp-api"
+ manifest="${tomcat.manifests}/jsp-api.jar.manifest"
+ notice="${tomcat.manifests}/jsp-api.jar.notice"
+ license="${tomcat.manifests}/jsp-api.jar.license" />
++-->
+
+ <!-- JSP 2.2 EL Implementation JAR File -->
++<!--
+ <jarIt jarfile="${el-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.el-api"
+ manifest="${tomcat.manifests}/el-api.jar.manifest" />
++-->
+
+ <!-- Bootstrap JAR File -->
+ <jarIt jarfile="${bootstrap.jar}"
+@@ -986,12 +994,14 @@
+ <target name="deploy" depends="package,build-docs,compile-webapp-examples"
+ description="Default. Builds a working Tomcat instance">
+
++<!--
+ <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
+ file="${tomcat-native.tar.gz}" />
+ <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
+ file="${commons-daemon.native.src.tgz}" />
+
+ <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
++-->
+
+ <!-- Copy scripts -->
+ <copy todir="${tomcat.build}/bin">
+@@ -1051,14 +1061,15 @@
+ <exclude name="${jdt.jar.filename}"/>
+ </fileset>
+ </delete>
++<!--
+ <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
+-
++-->
+ <!-- Add sources for examples -->
+ <antcall target="examples-sources" />
+-
++<!--
+ <copy file="${tomcat-dbcp.jar}" todir="${tomcat.build}/lib"
+ failonerror="false"/>
+-
++-->
+ <!-- build the jdbc-pool jar and source jar-->
+ <echo message="Building Tomcat JDBC pool libraries"/>
+ <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
+@@ -1681,7 +1692,7 @@
+
+ <target name="extras-webservices-prepare"
+ depends="extras-prepare"
+- description="Prepare to build web services extras package">
++ description="Prepare to build web services extras package" unless="noget">
+
+ <antcall target="downloadfile">
+ <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
+@@ -1886,6 +1897,7 @@
+ description="Create the Tomcat javadoc" >
+ <fail unless="java.7.home"
+ message="The java.7.home property must be set for javadoc build"/>
++<!--
+ <javadoc packagenames="javax.servlet.*"
+ excludepackagenames="javax.servlet.jsp.*"
+ sourcepath="${tomcat.dist}/src/java"
+@@ -1947,6 +1959,7 @@
+ <path location="${ant.core.lib}"/>
+ </classpath>
+ </javadoc>
++-->
+ <javadoc packagenames="javax.websocket.*"
+ sourcepath="${tomcat.dist}/src/java"
+ destdir="${tomcat.dist}/webapps/docs/websocketapi"
+@@ -1985,9 +1998,11 @@
+ <path refid="tomcat.webservices.classpath"/>
+ <path location="${ant.core.lib}"/>
+ </classpath>
++<!--
+ <link href="../servletapi"/>
+ <link href="../jspapi"/>
+ <link href="../elapi"/>
++-->
+ <link href="../websocketapi"/>
+ <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+ <link href="http://commons.apache.org/proper/commons-io/javadocs/api-release/"/>
+@@ -2642,7 +2657,7 @@
+ </target>
+
+ <target name="download-compile"
+- description="Download (and build) components necessary to compile" >
++ description="Download (and build) components necessary to compile" unless="noget">
+
+ <antcall target="downloadfile-2">
+ <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
+@@ -2699,7 +2714,7 @@
+ </target>
+
+ <target name="download-test-compile"
+- description="Download additional components for the tests" >
++ description="Download additional components for the tests" unless="noget">
+
+ <antcall target="downloadfile">
+ <param name="sourcefile" value="${junit.loc}"/>
+@@ -2727,7 +2742,7 @@
+ </target>
+
+ <target name="download-dist"
+- description="Download additional components for a distribution" >
++ description="Download additional components for a distribution" unless="noget">
+
+ <antcall target="downloadzip-2">
+ <param name="sourcefile.1" value="${tomcat-native.win.1}"/>
diff --git a/www-servers/tomcat/tomcat-7.0.75.ebuild b/www-servers/tomcat/tomcat-7.0.75.ebuild
new file mode 100644
index 000000000000..82056e890f42
--- /dev/null
+++ b/www-servers/tomcat/tomcat-7.0.75.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2 prefix user
+
+MY_P="apache-${P}-src"
+
+DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
+HOMEPAGE="http://tomcat.apache.org/"
+SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="7"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="extra-webapps websockets"
+
+RESTRICT="test" # can we run them on a production system?
+
+ECJ_SLOT="4.5"
+SAPI_SLOT="3.0"
+
+COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
+ dev-java/tomcat-servlet-api:${SAPI_SLOT}"
+RDEPEND="${COMMON_DEP}
+ websockets? ( >=virtual/jre-1.7 )
+ !websockets? ( >=virtual/jre-1.6 )
+ !<dev-java/tomcat-native-1.1.24"
+DEPEND="${COMMON_DEP}
+ websockets? ( >=virtual/jdk-1.7 )
+ !websockets? ( >=virtual/jdk-1.6 )
+ test? ( dev-java/ant-junit:0 )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ enewgroup tomcat 265
+ enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+src_prepare() {
+ default
+
+ # Remove bundled servlet-api
+ rm -rv java/javax/{el,servlet} || die
+
+ java-pkg_clean
+
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ # For use of catalina.sh in netbeans
+ sed -i -e "/^# ----- Execute The Requested Command/ a\
+ CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
+ bin/catalina.sh || die
+
+ java-pkg-2_src_prepare
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_BUILD_TARGET="deploy"
+EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
+EANT_NEEDS_TOOLS="true"
+EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
+
+# revisions of the scripts
+IM_REV="-r1"
+INIT_REV="-r1"
+
+src_compile() {
+ use websockets && EANT_EXTRA_ARGS+=" -Djava.7.home=${JAVA_HOME}"
+ EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ local dest="/usr/share/${PN}-${SLOT}"
+
+ java-pkg_jarinto "${dest}"/bin
+ java-pkg_dojar output/build/bin/*.jar
+ exeinto "${dest}"/bin
+ doexe output/build/bin/*.sh
+
+ java-pkg_jarinto "${dest}"/lib
+ java-pkg_dojar output/build/lib/*.jar
+
+ dodoc RELEASE-NOTES RUNNING.txt
+ use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
+ use source && java-pkg_dosrc java/*
+
+ ### Webapps ###
+
+ insinto "${dest}"/webapps
+ doins -r output/build/webapps/{host-manager,manager,ROOT}
+ use extra-webapps && doins -r output/build/webapps/{docs,examples}
+
+ ### Config ###
+
+ # create "logs" directory in $CATALINA_BASE
+ # and set correct perms, see #458890
+ dodir "${dest}"/logs
+ fperms 0750 "${dest}"/logs
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
+
+ # prepend gentoo.classpath to common.loader, see #453212
+ sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
+
+ insinto "${dest}"
+ doins -r output/build/conf
+
+ ### rc ###
+
+ cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
+ eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
+ sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
+
+ insinto "${dest}"/gentoo
+ doins "${T}"/tomcat.conf
+ exeinto "${dest}"/gentoo
+ newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
+ newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
+}
+
+pkg_postinst() {
+ elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
+ elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
+ elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
+
+ elog "To manage Tomcat instances, run:"
+ elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
+
+ ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+ ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+
+# einfo "Please read https://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
+}