summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/Manifest1
-rw-r--r--x11-libs/libast/libast-0.7.ebuild39
-rw-r--r--x11-libs/libast/libast-9999.ebuild52
-rw-r--r--x11-libs/libast/metadata.xml17
4 files changed, 109 insertions, 0 deletions
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
new file mode 100644
index 000000000000..0c03b067e5d4
--- /dev/null
+++ b/x11-libs/libast/Manifest
@@ -0,0 +1 @@
+DIST libast-0.7.tar.gz 508654 SHA256 52055cc0df0af58adc8c43cce6c9a2fff71c627a6bb0395073d353920dd1ebf0
diff --git a/x11-libs/libast/libast-0.7.ebuild b/x11-libs/libast/libast-0.7.ebuild
new file mode 100644
index 000000000000..6c66e0310ce6
--- /dev/null
+++ b/x11-libs/libast/libast-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="!sci-astronomy/ast
+ x11-libs/libXt
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}
diff --git a/x11-libs/libast/libast-9999.ebuild b/x11-libs/libast/libast-9999.ebuild
new file mode 100644
index 000000000000..a0dfd80590dd
--- /dev/null
+++ b/x11-libs/libast/libast-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+#ECVS_SERVER="cvs.sourceforge.net:/cvsroot/enlightenment"
+ECVS_SERVER="anoncvs.enlightenment.org:/var/cvs/e"
+ECVS_MODULE="eterm/libast"
+inherit eutils cvs autotools
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="!sci-astronomy/ast
+ x11-libs/libXt
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_unpack() {
+ cvs_src_unpack
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}
diff --git a/x11-libs/libast/metadata.xml b/x11-libs/libast/metadata.xml
new file mode 100644
index 000000000000..952e09eebabc
--- /dev/null
+++ b/x11-libs/libast/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<longdescription>
+LibAST is the Library of Assorted Spiffy Things. It contains many
+spiffy things, and it is a library. Thus, the ever-so-creative name.
+LibAST has been previously known as libmej, the Eterm helper library
+which nobody really understood and certainly never used. My current
+plan is to gradually remove some of the neat stuff from Eterm that
+could be made generic (things like the theme parsing engine, the
+command-line options parser, perhaps the event engine, ...) and place
+it here in the hopes that others will find them useful.
+</longdescription>
+</pkgmetadata>