summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/ubuntu-wallpapers/Manifest1
-rw-r--r--x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/ubuntu-wallpapers/Manifest b/x11-themes/ubuntu-wallpapers/Manifest
index fcaa07e53386..454f46695779 100644
--- a/x11-themes/ubuntu-wallpapers/Manifest
+++ b/x11-themes/ubuntu-wallpapers/Manifest
@@ -1 +1,2 @@
DIST ubuntu-wallpapers_18.10.2.orig.tar.gz 186856866 BLAKE2B 4cc8f3f0e95bdc28d25d5b664678b60b924d2fbbd0876c260f45320bcb64bec4ddb3889c16b1bba1fc2506eba5ce579987a9cf8b25c3748a1c4529b52813c64c SHA512 dadd84e0b0d6be010254577239001d423b06730690cce44031ec90b1c7fe28312afb0720f8da7758f069b81556662f8a3c231c50255695090bc932d3ec9496db
+DIST ubuntu-wallpapers_19.04.2.orig.tar.gz 201172357 BLAKE2B 0ee1b8073dc47260667377ebf293cfd867e56b2f46c909c9dc88dbe9f94e9090e716d0b352af72661ec9c5088b7d52fdacda4bb9c274e84a13a2ce030f304779 SHA512 324812015f04c7286e9f90d73bb671013fff386eaf7933998a1199ebc24dbd1bba4ca3f8fc526afe4e26df738662d6d033a90f99195380b7fb4cf09feb8e631b
diff --git a/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild
new file mode 100644
index 000000000000..d8144746a137
--- /dev/null
+++ b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Ubuntu wallpapers"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/ubuntu-wallpapers"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${MY_P}.orig.tar.gz"
+
+# Review copying file for updates
+LICENSE="CC-BY-SA-3.0 CC-BY-SA-2.0 CC-BY-2.0 CC-BY-SA-4.0"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/backgrounds
+ doins *.jpg *.png
+
+ insinto /usr/share/backgrounds/contest
+ doins contest/*.xml
+
+ for i in *.xml.in; do
+ insinto /usr/share/gnome-background-properties
+ newins ${i} ${i/.in/}
+ done
+
+ einstalldocs
+}