summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2019-06-01 20:36:00 +0200
committerAlbert Diserholt <albert@diserholt.com>2019-06-01 20:40:21 +0200
commit16d08e7337dd7357ba67b0a97a95aa032b99c4e0 (patch)
tree5b5b289beb150f18fbae19a490727ae3a187288b
parentAdded Godot 3.1.1 (diff)
downloadDrauthius-16d08e7337dd7357ba67b0a97a95aa032b99c4e0.tar.gz
Drauthius-16d08e7337dd7357ba67b0a97a95aa032b99c4e0.tar.bz2
Drauthius-16d08e7337dd7357ba67b0a97a95aa032b99c4e0.zip
Added aseprite-1.2.11
It needs a custom-built version of Skia, which has been included here. Signed-off-by: Albert Diserholt <albert@diserholt.com>
-rw-r--r--dev-games/aseprite-skia/Manifest1
-rw-r--r--dev-games/aseprite-skia/aseprite-skia-9999-r71.ebuild77
-rw-r--r--dev-games/aseprite/Manifest3
-rw-r--r--dev-games/aseprite/aseprite-1.2.11.ebuild91
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.11-system_libarchive.patch91
5 files changed, 263 insertions, 0 deletions
diff --git a/dev-games/aseprite-skia/Manifest b/dev-games/aseprite-skia/Manifest
new file mode 100644
index 0000000..83faa2e
--- /dev/null
+++ b/dev-games/aseprite-skia/Manifest
@@ -0,0 +1 @@
+EBUILD aseprite-skia-9999-r71.ebuild 1803 BLAKE2B 07b3ad81ed03d8bf06121dec8a65c588832e01c3aa92c2e3768a8ae0300201540b26a12e3b90b8206ba0ceea9e95603c9b8d7140375a4fd66564daa339bba8ec SHA512 eb173b50767178e15f1870f6a3c40087d7b0bce2f491c73326dd51b1dd7e0e8fb0dc4fe4722da3cb7e9fa192b0347b64bb2bc40af8c4cf72d46d04a2ec9f869e
diff --git a/dev-games/aseprite-skia/aseprite-skia-9999-r71.ebuild b/dev-games/aseprite-skia/aseprite-skia-9999-r71.ebuild
new file mode 100644
index 0000000..6be9906
--- /dev/null
+++ b/dev-games/aseprite-skia/aseprite-skia-9999-r71.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 git-r3
+
+DESCRIPTION="Skia library for Aseprite"
+HOMEPAGE="https://skia.org"
+
+EGIT_REPO_URI="https://github.com/aseprite/skia"
+EGIT_BRANCH="aseprite-m${PR/r/}"
+
+DEPOT_TOOLS_URI="https://chromium.googlesource.com/chromium/tools/depot_tools.git"
+DEPOT_TOOLS_COMMIT="master"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug webp"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-libs/expat
+ dev-util/ninja
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ webp? ( media-libs/libwebp )
+ sys-libs/zlib"
+BDEPEND=""
+
+src_unpack() {
+ git-r3_src_unpack
+
+ cd "${S}"
+ python2.7 tools/git-sync-deps || die "Failed to sync dependencies"
+
+ EGIT_BRANCH="$DEPOT_TOOLS_COMMIT"
+ git-r3_fetch "$DEPOT_TOOLS_URI"
+ git-r3_checkout "$DEPOT_TOOLS_URI" depot_tools
+}
+
+src_configure() {
+ local myskiaargs=(
+ is_debug=$(usex debug true false)
+ is_official_build=true
+ skia_use_system_expat=true
+ skia_use_system_icu=false # Samples won't build
+ skia_use_system_libjpeg_turbo=true
+ skia_use_system_libpng=true
+ skia_use_system_libwebp=$(usex webp true false)
+ skia_use_system_zlib=true
+ )
+
+ cd "${S}"
+ export PATH="$PATH:${S}/depot_tools"
+ gn gen out/Release --args="${myskiaargs[*]}" || die "Failed to configure skia"
+}
+
+src_compile() {
+ ninja -C "out/$(usex debug Debug Release)" skia || die "Failed to compile skia"
+}
+
+src_install() {
+ insinto /var/lib/aseprite-skia/
+ doins -r include
+ insinto /var/lib/aseprite-skia/src
+ doins -r src/gpu
+ insinto /var/lib/aseprite-skia/third_party
+ doins -r third_party/skcms
+
+ insinto /var/lib/aseprite-skia/out/$(usex debug Debug Release)
+ dodir /var/lib/aseprite-skia/out/$(usex debug Debug Release)
+ newins out/*/libskia.a libskia.a
+}
diff --git a/dev-games/aseprite/Manifest b/dev-games/aseprite/Manifest
index b362ff0..9272a43 100644
--- a/dev-games/aseprite/Manifest
+++ b/dev-games/aseprite/Manifest
@@ -1,11 +1,14 @@
+AUX aseprite-1.2.11-system_libarchive.patch 3627 BLAKE2B da38e42aee63b4604c4cccd85216ff05f68a2f29c20d1c3f875e4be2399d459f46c831b97c103387c06eba5fe75a5b69f618b3341d8ec39538a90b6e079a7058 SHA512 47eb8e258d43d9196a186b5eed29695d7d5b1a675e4c7be1ae5f304929f615e67cac19a6bffc7f6c8111c0d26e06db52362fa095777f45f604d37c203e5ff7a1
AUX aseprite-1.2.7.2-system_libarchive.patch 3268 BLAKE2B 1f2b40321cfa6c7f973abf8adf467a49d2259262ed217e956a3002abf3e830fc97fc5414e36465fae8e8327dcf2c9497945961bdda8e7885e9f683027f39e5a6 SHA512 eb0588983620e77cc5e054f585f347a382e3a23517a04ddc0251beaf21869015e58ed5c964ddbfe17a79749cfb1b05ce0e71dab39fc8fe71558115b571493cce
AUX aseprite-1.2.9-system_libarchive.patch 3622 BLAKE2B 1b3d74497a8510c2988b86646823f1972a5f210dd690ede65a5f1c71cfaebdafe2c3f352a3a86dec006cd9d30a4f9d7532b33373d89f92eed4fe7e32e25e1af6 SHA512 0abf6d1329c1aa894adfb09a8a05418c063962bd606abbe2832b4f344911a76541ebed0181dbc1889620aff8d25c061c2a1940ec3fcb5cb65047f250a1676892
DIST Aseprite-v1.1.13-Source.zip 12809688 BLAKE2B e9d6d58cfeb4b07d63945025a31e5a52c2f65e59f01a65bc3ac2f8feef725b2caeef94f542c70132834280c3227a3a1cf7756a708f6970c12d4fd7aca4e646c3 SHA512 b6dd948223885bc9511a8a0f8427540011dc2a6a4ec3448d3461a5661c7de574487e2306024f9522240490b1784a4231818f2790466d106f8b21259c188ca258
+DIST Aseprite-v1.2.11-Source.zip 23751460 BLAKE2B 0ebbcd27dc004dbb42982dccf899786cd635e9c300c4c9d5d3eb28d5c4e33ba366dc52217f5dd78dcfd966531a07be1bd5e1b4b351292af7a43dbb2d96c7e7b5 SHA512 94e538b26d3ea0a6444c0dac92dc07154d26d4fb96f91735982637c13e008885b3e8fda310d73e5f6aa4384fe2f5c9e318587a048ebade1ca6d34f028276edc2
DIST Aseprite-v1.2.5-Source.zip 21167203 BLAKE2B e5630b093d0a0df54f9f5704d7a40aaa8f409b1c2a7aad5ad358d1eb735017f82f102c22d543f1945c1e8a74055d4da422aebeb13e03e10ccada0a21721d9576 SHA512 888c8fe43c6dbe94679e44bfb0fe805262e4a846a6eb8ea91ce6e007d6dff7a89eb195f168efaa9643ea058205850ce979280f324b45c2d4c20a14be26c21877
DIST Aseprite-v1.2.6-Source.zip 20560401 BLAKE2B eed9de0b05f40c42396ed92d08bac5badf3f21f206d96de0b55890c3f105258534f841a0af09648884899960eafd5b63623ab40f6e878154bdfa2a454eab830a SHA512 e2e7316f0ac723dff86e23759135dc662cfe7bfc8c63160c4066c8503c92eebbf05a3b6f8003581d8daaa77eee62060e575c825a6e34020157ecdfc6e3def418
DIST Aseprite-v1.2.7.2-Source.zip 20599047 BLAKE2B d5150b99aa6343a60921212c4edddd06cc1e90e9f4e487fbc37e66b2475a5a53eedbfc4ac10f72a2843f4f8b67ee5ce42a677d2a72506f999c11c10de84fa478 SHA512 6f10793a82862c862a8b95010f14617d18367a7a24c554530661dd4218d89b50b1c43d10676bf2a66499b1403bc66cc1d557573a1a4850e1ed07353cf7a11286
DIST Aseprite-v1.2.9-Source.zip 23723562 BLAKE2B 6fd168cbd7f8b2fe4e9aae4ad2a14f99ff83f0c8b79142a1ec9c9ee483fd48a4c99dfb754a6071d6cd196951443064442af83405a132d8a6a18cdb4f42bb8da8 SHA512 24800a770d44ebe8ecafb26d454a30c78f5bf7321f14c80711efc2ff101fcaf936b400ee0db256e30ab04864f01b30fa3c1e6523b6b169476da023e2659968db
EBUILD aseprite-1.1.13.ebuild 3008 BLAKE2B 7419fdaaa1d9506d841ec9c0af3fa04b930afa98373accff9c9d6ee150d9e2ff3c64e670a800c1e40a118f608b2a6f362a779637c397f77a90802a97eef9557d SHA512 58cb3df2e8b33502021b90adde0459004507c9809ee4e0a06f5ddcbefef3c9758cd7374e7f529309a1c876a98e8983305e18f7f9344350221470a7bcebe9ce49
+EBUILD aseprite-1.2.11.ebuild 1946 BLAKE2B 834aad940270ca648078ea1269d2930e4b520f2bdcbdbcc4003665b51f334cece4c96d022e3baff5f17dd1ea27470c6a87291af64c1bf3af3489bc258ccfeeaa SHA512 3800fd3e40116ad8cf4b6bc945566d7d20ba4ae9c3e017593718ae798e86ed690e204dc28c937fb9c50e077955b6a8984fd6554a38e3ac498f11ffb4c711995f
EBUILD aseprite-1.2.5.ebuild 2909 BLAKE2B 9f4c4fba6634a9f26764eb36af00b03dafaa9039ee44fc6b5a988cd58fad22b83346fa16bd379b21480ca105f5d72c06749c1fce258d0ef16d5eb18b22fd6173 SHA512 a31092536e076644e8bf4db4bf9dcf36981040b82252c5ab83a1cff1763281b4fd49b205abcc5a584246e417df85c0fc9c3e349483a2e62057e1361b261254a1
EBUILD aseprite-1.2.6.ebuild 2909 BLAKE2B 9f4c4fba6634a9f26764eb36af00b03dafaa9039ee44fc6b5a988cd58fad22b83346fa16bd379b21480ca105f5d72c06749c1fce258d0ef16d5eb18b22fd6173 SHA512 a31092536e076644e8bf4db4bf9dcf36981040b82252c5ab83a1cff1763281b4fd49b205abcc5a584246e417df85c0fc9c3e349483a2e62057e1361b261254a1
EBUILD aseprite-1.2.7.2.ebuild 2908 BLAKE2B bf5176a5ccfca118b59eec443c887438c0c639d4d58a1daa03f033469d0470a96fe3e63d23dc79df680521e953cdc444d955e803c19fd0f709e10fb7315cfcdc SHA512 54aae3c01062800b68819a460c922709bc3065b3a85182f51157583920917d35f756ec65672ada20b47a8877d7d2f2f89b64b3a83171bb9a02d0f1e82bd65a2b
diff --git a/dev-games/aseprite/aseprite-1.2.11.ebuild b/dev-games/aseprite/aseprite-1.2.11.ebuild
new file mode 100644
index 0000000..0e544a9
--- /dev/null
+++ b/dev-games/aseprite/aseprite-1.2.11.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="http://www.aseprite.org"
+LICENSE="Proprietary"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-system_libarchive.patch" )
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/aseprite/aseprite"
+ EGIT_BRANCH="master"
+ if [[ ${PV} != 9999* ]]; then
+ EGIT_COMMIT="v${PV/_/-}"
+ fi
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV//_/-}/${PN^}-v${PV//_/-}-Source.zip"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"
+fi
+
+IUSE="
+ debug
+ memleak
+ webp"
+
+RDEPEND="
+ app-arch/libarchive
+ app-text/cmark
+ dev-libs/expat
+ dev-libs/tinyxml
+ =dev-games/aseprite-skia-9999-r71[debug=]
+ media-libs/freetype:2
+ >=media-libs/giflib-5.0
+ media-libs/fontconfig
+ media-libs/libpng:0
+ webp? ( !!media-libs/libwebp )
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib
+ virtual/jpeg:=
+ x11-libs/libX11
+ x11-libs/pixman"
+DEPEND="$RDEPEND
+ app-arch/unzip"
+
+DOCS=( EULA.txt
+ docs/ase-file-specs.md
+ docs/LICENSES.md
+ README.md )
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ use debug && CMAKE_BUILD_TYPE=Debug || CMAKE_BUILD_TYPE=Release
+
+ local mycmakeargs=(
+ -DENABLE_UPDATER=OFF
+ -DFULLSCREEN_PLATFORM=ON
+ -DBUILD_GMOCK=OFF
+ -DUSE_SHARED_CMARK=ON
+ -DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_GIFLIB=ON
+ -DUSE_SHARED_JPEGLIB=ON
+ -DUSE_SHARED_ZLIB=ON
+ -DUSE_SHARED_LIBARCHIVE=ON
+ -DUSE_SHARED_LIBPNG=ON
+ -DUSE_SHARED_TINYXML=ON
+ -DUSE_SHARED_PIXMAN=ON
+ -DUSE_SHARED_FREETYPE=ON
+ -DUSE_SHARED_HARFBUZZ=ON
+ -DWITH_WEBP_SUPPORT="$(usex webp)"
+ -DENABLE_MEMLEAK="$(usex memleak)"
+ -DSKIA_DIR="/var/lib/aseprite-skia"
+ -DSKIA_OUT_DIR="/var/lib/aseprite-skia/out/Release"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "Aseprite is for personal use only. You may not distribute it."
+}
diff --git a/dev-games/aseprite/files/aseprite-1.2.11-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.11-system_libarchive.patch
new file mode 100644
index 0000000..467b5b1
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.2.11-system_libarchive.patch
@@ -0,0 +1,91 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dae638be8..dd5d17794 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -64,6 +64,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
+ option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
+ option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
+ option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
++option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
+ option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
+ option(USE_SHARED_LIBLOADPNG "Use your installed copy of libloadpng" off)
+ option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
+@@ -193,6 +194,15 @@ else()
+ endif()
+ include_directories(${ZLIB_INCLUDE_DIRS})
+
++# libarchive
++if(USE_SHARED_LIBARCHIVE)
++ find_library(ARCHIVE_LIBRARIES NAMES archive)
++ find_path(ARCHIVE_INCLUDE_DIRS NAMES archive.h)
++else()
++ add_definitions(-DLIBARCHIVE_STATIC)
++ set(ARCHIVE_LIBRARIES archive_static)
++endif()
++
+ # libpng
+ if(USE_SHARED_LIBPNG)
+ find_package(PNG REQUIRED)
+@@ -294,7 +304,7 @@ if(USE_SHARED_CMARK)
+ else()
+ add_definitions(-DCMARK_STATIC_DEFINE)
+ set(CMARK_LIBRARIES libcmark_static)
+- include_directories(${CMAKE_CURRENT_BINARY_DIR}/third_party/cmark)
++ include_directories(${CMARK_DIR})
+ endif()
+
+ if(REQUIRE_CURL)
+diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
+index a9e80d73c..619acac92 100644
+--- a/src/app/CMakeLists.txt
++++ b/src/app/CMakeLists.txt
+@@ -82,9 +82,6 @@ if(WITH_WEBP_SUPPORT)
+ add_definitions(-DASEPRITE_WITH_WEBP_SUPPORT)
+ endif()
+
+-# libarchive definitions
+-add_definitions(-DLIBARCHIVE_STATIC)
+-
+ ######################################################################
+ # app-lib target
+
+@@ -551,7 +548,7 @@ target_link_libraries(app-lib
+ ${FREETYPE_LIBRARIES}
+ ${HARFBUZZ_LIBRARIES}
+ json11
+- archive_static
++ ${ARCHIVE_LIBRARIES}
+ fmt
+ tinyexpr)
+
+diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
+index 596ffa2e4..977816439 100644
+--- a/third_party/CMakeLists.txt
++++ b/third_party/CMakeLists.txt
+@@ -113,15 +113,17 @@ endif()
+ add_subdirectory(json11)
+
+ # libarchive
+-set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
+-set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
+-set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
+-set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
+-set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
+-set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
+-add_subdirectory(libarchive)
+-target_include_directories(archive_static INTERFACE
+- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
++if(NOT USE_SHARED_LIBARCHIVE)
++ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
++ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
++ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
++ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
++ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
++ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
++ add_subdirectory(libarchive)
++ target_include_directories(archive_static INTERFACE
++ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
++endif()
+
+ # benchmark
+ if(ENABLE_BENCHMARKS)