summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2019-04-20 17:33:24 +0200
committerAlbert Diserholt <albert@diserholt.com>2019-04-20 17:35:07 +0200
commitdb040392c55c6ab04313a8ae82b8a3717e51d4c6 (patch)
tree3a7988cb7b4ce6ca92317946552ab42a770699a2 /dev-games
parentAdded new versions of aseprite. (diff)
downloadDrauthius-db040392c55c6ab04313a8ae82b8a3717e51d4c6.tar.gz
Drauthius-db040392c55c6ab04313a8ae82b8a3717e51d4c6.tar.bz2
Drauthius-db040392c55c6ab04313a8ae82b8a3717e51d4c6.zip
Added godot-3.1
Doesn't respect all builtins, but that's a mystery for another time. Signed-off-by: Albert Diserholt <albert@diserholt.com>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/Manifest2
-rw-r--r--dev-games/godot/godot-3.1.ebuild126
2 files changed, 128 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
new file mode 100644
index 0000000..77cb6cb
--- /dev/null
+++ b/dev-games/godot/Manifest
@@ -0,0 +1,2 @@
+DIST 3.1-stable.zip 25495857 BLAKE2B 321323b21b9d845939b94e60d9cfc7894cbbb6b09ba8d8d8fbaa1440441dd14fa5d2ba8fb67738f965fc4f64d2dd6c11802cb1e49cb6dced6b514983cb070302 SHA512 df9c2a3d41095403321a3afba0c4943253723bbc602d4d5c238e31a25ce7f3660f066d1051e8c725f567d08f5a0a4f28c738d82aacbfc025e60f1a188c5692fe
+EBUILD godot-3.1.ebuild 3282 BLAKE2B ec32b7f3a6e5792d05070f815e170869703eab085cb316b4de58e476b3bca9ad0943fdbddbd8c3aaedb3d7cffb76038f794512f71c58315f46700c391936817d SHA512 dce4f255e5c1677bfec02c2226a9045d0a8c437bec47c6c518edc0f87d1f0a06695fc5f7abafd2be00ee925bcd61949903c6b84d973321cb782a190ca522e52b
diff --git a/dev-games/godot/godot-3.1.ebuild b/dev-games/godot/godot-3.1.ebuild
new file mode 100644
index 0000000..0eab0ba
--- /dev/null
+++ b/dev-games/godot/godot-3.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-any-r1 scons-utils
+
+DESCRIPTION="Multi-platform 2D and 3D game engine"
+HOMEPAGE="http://godotengine.org"
+LICENSE="MIT"
+SLOT="0"
+
+SRC_URI="https://github.com/godotengine/${PN}/archive/${PV}-stable.zip"
+S="${WORKDIR}/${P}-stable"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+enet +freetype +llvm pulseaudio theora +udev +vorbis +webp +websockets +mbedtls +opus"
+
+DEPEND="
+ >=app-arch/bzip2-1.0.6-r6
+ >=app-arch/lz4-0_p120
+ >=app-arch/xz-utils-5.0.8
+ >=dev-libs/json-c-0.11-r1
+ dev-libs/libpcre2[pcre32]
+ >=media-libs/alsa-lib-1.0.28
+ >=media-libs/flac-1.3.1-r1
+ >=media-libs/libogg-1.3.1
+ >=media-libs/libsndfile-1.0.25-r1
+ media-libs/libvpx
+ >=media-libs/mesa-10.2.8[gles2]
+ webp? ( media-libs/libwebp )
+ opus? ( media-libs/opus )
+ enet? ( net-libs/enet )
+ >=net-libs/libasyncns-0.8-r3
+ websockets? ( net-libs/libwebsockets )
+ mbedtls? ( net-libs/mbedtls )
+ net-libs/miniupnpc
+ >=sys-apps/attr-2.4.47-r1
+ >=sys-apps/tcp-wrappers-7.6.22-r1
+ >=sys-apps/util-linux-2.25.2-r2
+ >=sys-devel/gcc-4.6.4:*[cxx]
+ >=sys-libs/gdbm-1.11
+ >=sys-libs/glibc-2.20-r2
+ >=sys-libs/libcap-2.22-r2
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXcursor-1.1.14
+ >=x11-libs/libXinerama-1.1.3
+ freetype? ( >=media-libs/freetype-2.5.3-r1:2 )
+ llvm? ( >=sys-devel/llvm-3.6.0 )
+ >=media-libs/libpng-1.6.16:0=
+ pulseaudio? ( >=media-sound/pulseaudio-5.0-r7 )
+ theora? ( media-libs/libtheora )
+ udev? ( virtual/udev )
+ virtual/glu
+ vorbis? ( >=media-libs/libvorbis-1.3.4 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ MYSCONS=(
+ CC="$(tc-getCC)"
+ builtin_enet=$(usex enet)
+ builtin_freetype=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex theora)
+ builtin_libvorbis=$(usex vorbis)
+ builtin_libvpx=no
+ builtin_libwebp=$(usex webp)
+ builtin_libwebsockets=$(usex websockets)
+ builtin_mbedtls=$(usex mbedtls)
+ builtin_miniupnpc=no
+ builtin_opus=$(usex opus)
+ builtin_pcre2=no
+ builtin_zlib=no
+ #builtin_zstd=no # Compilation error due to undeclared identifiers
+ module_enet_enabled=$(usex enet)
+ module_freetype_enabled=$(usex freetype)
+ module_mbedtls_enabled=$(usex mbedtls)
+ module_opus_enabled=$(usex opus)
+ module_theora_enabled=$(usex theora)
+ module_vorbis_enabled=$(usex vorbis)
+ module_webp_enabled=$(usex webp)
+ module_websocket_enabled=$(usex websockets)
+ platform=x11
+ pulseaudio=$(usex pulseaudio)
+ tools=yes
+ udev=$(usex udev)
+ use_llvm=$(usex llvm)
+ )
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ newicon icon.svg ${PN}.svg
+ dobin bin/godot.*
+ if [[ "${ARCH}" == "amd64" ]]; then
+ if use llvm; then
+ make_desktop_entry godot.x11.tools.64.llvm Godot
+ with_desktop_entry=1
+ else
+ make_desktop_entry godot.x11.tools.64 Godot
+ with_desktop_entry=1
+ fi
+ fi
+
+ if [[ "${ARCH}" == "x86" ]]; then
+ if use llvm; then
+ make_desktop_entry godot.x11.tools.32.llvm Godot
+ with_desktop_entry=1
+ else
+ make_desktop_entry godot.x11.tools.32 Godot
+ with_desktop_entry=1
+ fi
+ fi
+
+ if ! [[ "${with_desktop_entry}" == "1" ]]; then
+ elog "Couldn't detect running architecture to create a desktop file."
+ fi
+}