summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Psota <jasiupsota@gmail.com>2017-12-22 11:59:34 +0100
committerJan Psota <jasiupsota@gmail.com>2017-12-22 11:59:34 +0100
commit203ba7d882044b7f159833cf4d414204484ddc06 (patch)
tree4c1a1ef81700df1101870d3726ff5e052b2eb6e5
parent2017-12-17 08:26:30 UTC (diff)
downloadbleeding-edge-203ba7d882044b7f159833cf4d414204484ddc06.tar.gz
bleeding-edge-203ba7d882044b7f159833cf4d414204484ddc06.tar.bz2
bleeding-edge-203ba7d882044b7f159833cf4d414204484ddc06.zip
media-libs/jasper-2.0.14 since 2017-09-14, .12 ebuild
-rw-r--r--media-libs/jasper/Manifest1
-rw-r--r--media-libs/jasper/jasper-2.0.14.ebuild63
-rw-r--r--media-libs/jasper/metadata.xml11
3 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/jasper/Manifest b/media-libs/jasper/Manifest
new file mode 100644
index 0000000..b9cb19d
--- /dev/null
+++ b/media-libs/jasper/Manifest
@@ -0,0 +1 @@
+DIST jasper-2.0.14.tar.gz 1311825 SHA256 85266eea728f8b14365db9eaf1edc7be4c348704e562bb05095b9a077cf1a97b SHA512 6b270cb1eb55f777f30016f3258e5e2297627e7d086334814c308464f5a4552c23241b0fdbc81ea715a6f4746294657f96c1cb6ceb320629ce57db7e81d84940 WHIRLPOOL 47647db21d133e226371b6cd448026300f720220c85fe14e00042173799d24b1df470a2b54242213f24f29f1da69859f6d02f92abd3a71d632905dcbc31a577b
diff --git a/media-libs/jasper/jasper-2.0.14.ebuild b/media-libs/jasper/jasper-2.0.14.ebuild
new file mode 100644
index 0000000..6e89a5e
--- /dev/null
+++ b/media-libs/jasper/jasper-2.0.14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
+HOMEPAGE="https://www.ece.uvic.ca/~mdadams/jasper/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+# We limit memory usage to 128 MiB by default, specified in bytes
+: ${JASPER_MEM_LIMIT:=134217728}
+
+LICENSE="JasPer2.0"
+SLOT="0/4"
+IUSE="doc jpeg opengl"
+
+RDEPEND="
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
+ >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DALLOW_IN_SOURCE_BUILD=OFF
+ -DBASH_PROGRAM="${EPREFIX}"/bin/bash
+ -DJAS_ENABLE_ASAN=OFF
+ -DJAS_ENABLE_LSAN=OFF
+ -DJAS_ENABLE_MSAN=OFF
+ -DJAS_ENABLE_SHARED=ON
+ -DJAS_ENABLE_STRICT=ON
+ -DJAS_ENABLE_USAN=OFF
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+
+ # JPEG
+ -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
+ -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
+
+ # OpenGL
+ -DJAS_ENABLE_OPENGL=$(usex opengl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
+
+ # Doxygen
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-libs/jasper/metadata.xml b/media-libs/jasper/metadata.xml
new file mode 100644
index 0000000..2925a23
--- /dev/null
+++ b/media-libs/jasper/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mdadams/jasper</remote-id>
+ </upstream>
+</pkgmetadata>