aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-07-06 03:32:19 +0200
committerMarco Leise <marco.leise@gmx.de>2019-07-06 03:56:34 +0200
commit5cc8acf255989eea15782e0fd2e95e4403cad06f (patch)
treee8ad76a2fb968473c61e9a121305c01bb278a7c0
parentonedrive-2.3.5 (diff)
downloaddlang-5cc8acf255989eea15782e0fd2e95e4403cad06f.tar.gz
dlang-5cc8acf255989eea15782e0fd2e95e4403cad06f.tar.bz2
dlang-5cc8acf255989eea15782e0fd2e95e4403cad06f.zip
onedrive-2.3.7
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.3.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 3b09c7f..1ad6531 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1,2 +1,3 @@
DIST onedrive-2.3.3.tar.gz 599457 BLAKE2B 71dc2dcb4c725156d480565ab2a884acb4ba9a51d8e44c34e02de7cb815b6fd5eff71bc2c2ea6cc5eaf663f2cb4e87dee8c432ccfc682bd4a64ffdd0e74234ee SHA512 71103c4733620022a3b9cd73caf9b7b38b1549f167798659ee04503360c43b72d078c030a8314d5abf961e1e11b35ac19fd71b4f2902177471e793d1001f29d7
DIST onedrive-2.3.5.tar.gz 644951 BLAKE2B fc236f8212f086ab5c31a8ee95751a4a1da3bae205797936acf9a1d7414a379d9e9592266ca7ebe61f31773f3c5f29ca2b42c38acb14476c0d8729f60437a4f1 SHA512 824cc8eaea4847542052673bcf1e6e208fc2f3d18697c45610b4ab74be25b62992be0e86f6bbdaa7523c82e4c5fa18de5689506e3d79931531bbf8a17a8328d5
+DIST onedrive-2.3.7.tar.gz 646097 BLAKE2B b92ca1cd91662daea1da16330af0d3be7b47d1059c2d5267072fc8daea637885646d2a8fda66c3fcf1be6fd559254f87049aed753fba8ecab32fbc78301b4077 SHA512 823a448b8f36b06c9142cfec96bdaf4a71f856961ece23d9f0cd5051be12f46b304684c3362a68770c6d174754e658094ad3292b599bdce4b434ee0e044d090b
diff --git a/net-misc/onedrive/onedrive-2.3.7.ebuild b/net-misc/onedrive/onedrive-2.3.7.ebuild
new file mode 100644
index 0000000..9a8d439
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.3.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://github.com/skilion/onedrive"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+src_prepare() {
+ mkdir .git
+ touch .git/HEAD .git/index
+ echo "v${PV}" > version
+ default_src_prepare
+}
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "The 'skilion' version contains a significant number of defect's in how the"
+ ewarn "local sync state is managed. When upgrading from the 'skilion' version to this"
+ ewarn "version, it is advisable to stop any service / onedrive process from running"
+ ewarn "and then remove your configuration directory (~/.config/onedrive/)."
+}