aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-04-21 18:49:27 +0200
committerMarco Leise <marco.leise@gmx.de>2019-04-21 18:49:27 +0200
commita10d05367d1ff0ab66d1de98720d4a181d6be9c0 (patch)
tree51b0ff2bd6a5206f13b045620d61d81684a271fb
parentdcd-0.11.1 (diff)
downloaddlang-a10d05367d1ff0ab66d1de98720d4a181d6be9c0.tar.gz
dlang-a10d05367d1ff0ab66d1de98720d4a181d6be9c0.tar.bz2
dlang-a10d05367d1ff0ab66d1de98720d4a181d6be9c0.zip
Prevent ldc2 from building with llvm 7.1, which is not supported.
-rw-r--r--dev-lang/ldc2/ldc2-1.12.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.13.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.14.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.15.0.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/ldc2/ldc2-1.12.0.ebuild b/dev-lang/ldc2/ldc2-1.12.0.ebuild
index fe783e6..c50602a 100644
--- a/dev-lang/ldc2/ldc2-1.12.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.12.0.ebuild
@@ -20,7 +20,7 @@ IUSE="static-libs"
# We support LLVM 3.7 through 7.
RDEPEND="|| (
- sys-devel/llvm:7
+ sys-devel/llvm:7/7.0
sys-devel/llvm:6
sys-devel/llvm:5
sys-devel/llvm:4
diff --git a/dev-lang/ldc2/ldc2-1.13.0.ebuild b/dev-lang/ldc2/ldc2-1.13.0.ebuild
index db77fac..04ee3d9 100644
--- a/dev-lang/ldc2/ldc2-1.13.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.13.0.ebuild
@@ -20,7 +20,7 @@ IUSE="static-libs"
# We support LLVM 3.9 through 7.
RDEPEND="|| (
- sys-devel/llvm:7
+ sys-devel/llvm:7/7.0
sys-devel/llvm:6
sys-devel/llvm:5
sys-devel/llvm:4
diff --git a/dev-lang/ldc2/ldc2-1.14.0.ebuild b/dev-lang/ldc2/ldc2-1.14.0.ebuild
index db77fac..04ee3d9 100644
--- a/dev-lang/ldc2/ldc2-1.14.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.14.0.ebuild
@@ -20,7 +20,7 @@ IUSE="static-libs"
# We support LLVM 3.9 through 7.
RDEPEND="|| (
- sys-devel/llvm:7
+ sys-devel/llvm:7/7.0
sys-devel/llvm:6
sys-devel/llvm:5
sys-devel/llvm:4
diff --git a/dev-lang/ldc2/ldc2-1.15.0.ebuild b/dev-lang/ldc2/ldc2-1.15.0.ebuild
index a8511e6..2a1ae8c 100644
--- a/dev-lang/ldc2/ldc2-1.15.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.15.0.ebuild
@@ -21,7 +21,7 @@ IUSE="static-libs"
# We support LLVM 3.9 through 8.
RDEPEND="|| (
sys-devel/llvm:8
- sys-devel/llvm:7
+ sys-devel/llvm:7/7.0
sys-devel/llvm:6
sys-devel/llvm:5
sys-devel/llvm:4