aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-04-21 14:33:58 +0200
committerMarco Leise <marco.leise@gmx.de>2019-04-21 14:33:58 +0200
commit574e87d357691d4c5dc509c27c4218afb49d6d21 (patch)
treeaac41413538720ce55258dacda85475bf45844bb /dev-util/dfmt
parentdscanner-0.7.1 (diff)
downloaddlang-574e87d357691d4c5dc509c27c4218afb49d6d21.tar.gz
dlang-574e87d357691d4c5dc509c27c4218afb49d6d21.tar.bz2
dlang-574e87d357691d4c5dc509c27c4218afb49d6d21.zip
dfmt-0.10.1
Diffstat (limited to 'dev-util/dfmt')
-rw-r--r--dev-util/dfmt/Manifest3
-rw-r--r--dev-util/dfmt/dfmt-0.10.1.ebuild57
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/dfmt/Manifest b/dev-util/dfmt/Manifest
index bd6b20c..d8ba090 100644
--- a/dev-util/dfmt/Manifest
+++ b/dev-util/dfmt/Manifest
@@ -1,3 +1,6 @@
+DIST dfmt-0.10.1.tar.gz 85212 BLAKE2B f37bead92ef35beb404461093faaa495b88f59b53f07ae9c5e6b529d7998ad6cd662e5ff8f9d62405a1df61569612482c26de5065b1351bb1a8e0f5ecfde9b73 SHA512 9304051e2892696f35a596642b09fe8f177f1a02a9b1d7f56388f6f04d21ab015286aa8e1357fe9ea69a4b6c48572b204958a4811cff4507eef41ce68aa3d664
DIST dfmt-0.9.0.tar.gz 81100 BLAKE2B 1c19ad11d8b02091114b5c1650db5befa0318db09caea6c53f358598c0d0d61ebb3b300f3905ab8c48e78872b5b2d779b01d233e6ec4d29dc7fcfe10fb8e9ac6 SHA512 68d0b3eeecc0c2971c4b3da4b76b9e5466650fc84749b6f247a3c7b66cce25416f49722942e209b92a441e570d5f340bad584ca6ddcf4372a971d544d7df8467
+DIST libdparse-aae371931a99027465952cd6fdaede4eb4743e76.tar.gz 122507 BLAKE2B ae0b500875fad7929ac5450303fe8fd1064299fb2bfd3378fd97f41aa3ca4a3d0a3c4df3be66985489a31fa56d613c031621f630b16668f7747bd8fb198c11bd SHA512 2aa54664bcaf8a974a00559354fb0115b8cc98b6cb299644b48086c70fa28ae12c90c573f030e2028ff33db7f8bb654813a8c7d1ec5078f1980a5b29ef35dda0
DIST libdparse-ea63487efde96b6f169065d801bbcb8d7ed5dbb4.tar.gz 120550 BLAKE2B d7114362fdb5ba582ff8a6de35f689c00ed436ba9575e1cf373a7d8688e8487f9c4759f77102760beb859856e1cc02a90babc2c94a19a7fd5b5592e851feca6c SHA512 860b6c38d7fc7a2b5da981390e1c4b10cedb2da7419df6bbb3fc1fa46ac647235ee07baa532ca7bdf8095b0d7a2cdabcf20bc8efb73f5fc8491af6b57b3ed216
+DIST stdx-allocator-ae237cabd1843774cc78aad0729c914a3dd579db.tar.gz 103650 BLAKE2B 8d03c2dc76194b18da92261c533c402b87bda1964662070d02ceacbab3dda91a834c0c8bfe45feb1d9a3d7669f96a2a1f7b9a6b7eff7ea53069480d8de8fe15e SHA512 893e5ecefac86a64b3a91f034cc9f42aabc264d111b40accf890b505ec9d077fcaac0b29fc202400448994e4ff021263beef7716798734cb9b71b6aad1aaf394
DIST stdx-allocator-b7778fd6bf5f9aaaa87dd27f989cefbf9b3b365f.tar.gz 103550 BLAKE2B be33b0df3a9be5a718c0f2286805946f2c20841bdf7032a4f454b7be76958a5789afaca94f430023918c25764f67fa5966f34fef1d7ca023e04a27735d5eda1b SHA512 d9a7688a45649a39d6a464a2f6a3acb0ee29b3aa17065afccc79d905701fc38fe48dd329687c065a016fc5f5291bb18e3e5b2877a286fd3e509766c7d9962e25
diff --git a/dev-util/dfmt/dfmt-0.10.1.ebuild b/dev-util/dfmt/dfmt-0.10.1.ebuild
new file mode 100644
index 0000000..6cf7a98
--- /dev/null
+++ b/dev-util/dfmt/dfmt-0.10.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dfmt is a formatter for D source code"
+HOMEPAGE="https://github.com/dlang-community/dfmt"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LIBDPARSE="aae371931a99027465952cd6fdaede4eb4743e76"
+ALLOCATOR="ae237cabd1843774cc78aad0729c914a3dd579db"
+SRC_URI="
+ https://github.com/dlang-community/dfmt/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz
+ https://github.com/dlang-community/libdparse/archive/${LIBDPARSE}.tar.gz -> libdparse-${LIBDPARSE}.tar.gz
+ https://github.com/dlang-community/stdx-allocator/archive/${ALLOCATOR}.tar.gz -> stdx-allocator-${ALLOCATOR}.tar.gz
+ "
+
+DLANG_VERSION_RANGE="2.075-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang bash-completion-r1
+
+src_prepare() {
+ mkdir bin || die "Failed to create 'bin' directory."
+ cat > bin/githash.txt << EOF
+v${PV}
+EOF
+ dlang_src_prepare
+}
+
+d_src_compile() {
+ local libdparse_src="../libdparse-${LIBDPARSE}/src"
+ local allocator_src="../stdx-allocator-${ALLOCATOR}/source"
+ local imports="src ${libdparse_src} ${allocator_src}"
+ local string_imports="bin"
+
+ dlang_compile_bin "bin/dfmt" "src/dfmt/main.d" "src/dfmt/config.d" "src/dfmt/editorconfig.d" \
+ "src/dfmt/ast_info.d" "src/dfmt/indentation.d" "src/dfmt/tokens.d" "src/dfmt/wrapping.d" \
+ "src/dfmt/formatter.d" "src/dfmt/globmatch_editorconfig.d" \
+ ${libdparse_src}/dparse/lexer.d ${libdparse_src}/dparse/parser.d ${libdparse_src}/dparse/ast.d \
+ ${libdparse_src}/dparse/rollback_allocator.d ${libdparse_src}/dparse/stack_buffer.d \
+ ${libdparse_src}/std/experimental/lexer.d \
+ ${allocator_src}/stdx/allocator/common.d ${allocator_src}/stdx/allocator/mallocator.d \
+ ${allocator_src}/stdx/allocator/package.d ${allocator_src}/stdx/allocator/gc_allocator.d
+}
+
+d_src_test() {
+ cd tests && ./test.sh
+}
+
+d_src_install() {
+ dobin bin/dfmt
+ dodoc README.md LICENSE.txt
+ dobashcomp bash-completion/completions/dfmt
+}